no url sent to external RSS reader

RESOLVED INVALID

Status

()

Firefox
RSS Discovery and Preview
--
major
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: pascalc, Unassigned)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a8pre) Gecko/2007092104 Minefield/3.0a8pre ID:2007092104

Firefox 3 does not send URL feeds to external rss readers.

Steps to reproduce the web:
1/ go to http://robert.accettura.com/feed/atom/
2/ in the subscription top pane choose an external app like /usr/bin/liferea-add-feed  if you use Liferea

expected result:
feed is added into Liferea

actual result:
an invalid feed is sent, according to Liferea the url is just file:///

This works perfectly in Firefox 2, hence the regression keyword.
(Reporter)

Updated

11 years ago
Flags: blocking-firefox3?
Version: unspecified → Trunk
I can't reproduce that result with my mangy old version of liferea (I just get a hung attempt to subscribe to robert.accettura.com/feed/atom/ with no protocol), but even trunk liferea's handling of feed: URLs is completely broken: http://liferea.svn.sourceforge.net/viewvc/liferea/trunk/liferea/src/subscription.c?view=markup#l_58 will only work for URLs of the optional style that was removed between version 01 and 02 of the feed: pre-draft because it fails to comply with URI syntax.

It only removes "feed://", so it will break for feed:https://example.com, and the code later on apparently doesn't expect just "example.com" so it will break for feed://example.com. The only thing that will work for is feed://http://example.com, which was one of the optional forms for what I think was a few weeks in December 2003.
Conveniently, I linked to the trunk version of subscription.c, so you can see he's already fixed it (for the feed:// case, though I think not for the feed:https:// case).

I'd say "invalid, not our bug" except that "just file:///" part worries me. What version of Liferea, what prefs for feed handling, what happens in a new clean profile?
(Reporter)

Comment 4

11 years ago
my version of Liferea is 1.4.4, tested with a fresh profile and as I said in my initial report, following the same steps to add the same feeds from firefox 2 to Liferea works so I believe the problem is on our side. I am travelling for the next two days, when i get back home I'll try with other feed readers to see if it is liferea-only or general.
We changed from sending ambiguous "http://example.org/foo/" URLs in Fx2 to sending clear feed subscription requests with "feed://example.org/foo/" URLs in Fx3, but just because we changed from doing something which did work with Liferea to something which didn't before (the unreleased) 1.4.10 doesn't mean it's our bug.

So if you're getting the same result you get from |/usr/bin/liferea-add-feed feed://robert.accettura.com/feed/atom/|, and approximately the same as adding that URI through the UI, then I'm not worried, it's just a Liferea bug that's fixed in trunk code, and it's a shame that apparently nobody used the OS X port, since both Fx2 and all versions of Safari that know about RSS have always done feed:// URIs on OS X.

I just don't see "file:///" in any possible way of subscribing (other than that adding a feed:// URI through the UI says "there is no file robert.accettura.com/feed/atom/"), so *that* part worries me.
(Reporter)

Comment 6

11 years ago
If I type /usr/bin/liferea-add-feed feed://robert.accettura.com/feed/atom/ in a terminal, I get the same buggy result as if I add it through firefox:

Feed: File:///
Source: File:///robert.accettura.com/feed/atom/

So it really looks like a Liferea bug, marking invalid then, thanks for looking Phil.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Flags: blocking-firefox3?
You need to log in before you can comment on or make changes to this bug.