Regression - Redrawing screen is not always called when there are changes to DOM

RESOLVED FIXED

Status

()

Core
SVG
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Bruce Rindahl, Assigned: tor)

Tracking

unspecified
x86
Windows XP
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007120505 Minefield/3.0b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007120505 Minefield/3.0b2pre

In the above URL clicking on the little "X" on the windows sets the "display" attribute to "none" but the window remains viewable.  Do anything to force a redraw of the screen (view a different tab, resize, etc.) and the window element will then disappear.  The behavior can be duplicated in the DOM inspector.  Refresh the above URL, open the DOM inspector, expand the svg node and look for the text node with the id "titleText".  Delete this node and the display will still show the text "Demonstration of the Window Object".  Force a redraw and it will disappear.

Reproducible: Always

Steps to Reproduce:
1.See details
2.
3.



Firefox 2.0.0.11 works fine in this URL
(Assignee)

Comment 1

10 years ago
Possible regression from bug 401112.
(Assignee)

Comment 2

10 years ago
Created attachment 291687 [details] [diff] [review]
containers don't have a cached rect
Assignee: nobody → tor
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #291687 - Flags: superreview?(roc)
Attachment #291687 - Flags: review?(jwatt)
(Assignee)

Updated

10 years ago
Flags: blocking1.9+
Attachment #291687 - Flags: superreview?(roc) → superreview+
(Reporter)

Comment 3

10 years ago
Will this land soon?  I have some other issues that I think are related to this but I want to see if the patch will fix it.  Thanks!
Comment on attachment 291687 [details] [diff] [review]
containers don't have a cached rect

I thought I already gave this r=jwatt. Sorry.
Attachment #291687 - Flags: review?(jwatt) → review+
Blocks: 408972
(Assignee)

Comment 5

10 years ago
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Duplicate of this bug: 409149
Duplicate of this bug: 411979
You need to log in before you can comment on or make changes to this bug.