can't Paste, Cut, Copy, or Select All in Save Page As dialog box

RESOLVED DUPLICATE of bug 372571

Status

()

Core
Event Handling
--
major
RESOLVED DUPLICATE of bug 372571
11 years ago
11 years ago

People

(Reporter: Allen Stenger, Unassigned)

Tracking

({dogfood, regression})

Trunk
PowerPC
Mac OS X
dogfood, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b2pre) Gecko/2007120904 Minefield/3.0b2pre
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b2pre) Gecko/2007120904 Minefield/3.0b2pre

Pasting of text into the dialog box on Save Page As is disabled or does not work, even if there is something in the clipboard. Also, Select All, Cut, and Copy of the Save As text does not work. See "Steps to Reproduce" for conditions.

Note: works correctly in Firefox 3.0.0.11

Reproducible: Always

Steps to Reproduce:
1. go to http://www.mozilla.org/
2. drag to select the text "Looking for Firefox" near the top
3. command Edit> Copy
4. command File> Save Page As
5. observe that the Save As text field is highlighted in the dialog box (good)
6. click in the Save As text field to deselect the text
7. command Edit> Select All
8. observe that text is not highlighted (bad)
9. pull down the Edit menu, observe that Paste is disabled (bad)
10. cancel save dialog
11. click in "search mozilla" input box at upper right
12. command Edit> Paste, observe "Looking for Firefox" text is pasted correctly
13. command File> Save Page As
14. pull down the Edit menu, observe that Paste is enabled (good), observe that Cut and Copy are disabled (bad)
15. command Edit> Paste
16. observe that text is not pasted (bad)
Actual Results:  
See "Steps to Reproduce"

Expected Results:  
See "Steps to Reproduce"

Comment 1

11 years ago
I see this as well, using Beta 2 on both Mac OS 10.4.11 and Mac OS 10.5.1.  The keyboard shortcuts don't work either (Cmd-C, Cmd-V, etc.).  This doesn't come up all that often for me, but it's pretty irritating when it does; I'm not sure if that qualifies it as blocking Firefox 3, but it's certainly an embarrassing regression as far as polish goes.  (I /think/ the regression keyword is appropriate here.)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Version: unspecified → Trunk

Comment 2

11 years ago
The more I think about it, the more I'd really like to have someone driving the project make the call on whether this is a blocking issue.  I'll set the flag.
Flags: blocking-firefox3?
A regression window would help.
http://wiki.mozilla.org/QA/Triage#How_to_Help_with_Regressions_--_Finding_Regression_Windows
Severity: normal → major
Component: Menus → Event Handling
Flags: blocking-firefox3? → in-litmus?
Keywords: dogfood
Product: Firefox → Core
QA Contact: menus → events
Flags: blocking1.9?

Comment 4

11 years ago
Yikes.  The regression occurred between 2006-09-28-08 and 2006-09-29-06, and the obvious hulking target for the blame is bug 326469, "make Cocoa widgets default for all products on trunk".  That sounds like a frighteningly large set of changes to hunt through to me, but perhaps the folks involved with that transition know the code well enough to find the bug easily.  I'm adding Josh Aas to the CC list here on the assumption that Cocoa widgets are the issue.

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Flags: in-litmus?
Flags: blocking1.9?
Resolution: --- → DUPLICATE
Duplicate of bug: 372571
You need to log in before you can comment on or make changes to this bug.