Order in task list does not update if sorted by due date and a due date has changed

RESOLVED WORKSFORME

Status

Calendar
Tasks
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: aryx, Unassigned)

Tracking

({regression})

Details

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12pre) Gecko/20071209 Calendar/0.8pre

1. Have a task list with due dates, sort the tasks by the due date.
2. Edit a task with a due date from the past, set it to the future.
3. See that the task does not change its position in the list.
Confirmed using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13pre) Gecko/20080212 Lightning/0.8pre (2008021219) Thunderbird/2.0.0.13pre.
OS: Windows XP → All
Hardware: PC → All
Version: Mozilla 1.8 Branch → unspecified
Confirmed with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8pre) Gecko/20071022 Lightning/0.8pre (2008021219) Thunderbird/2.0.0.6 ID:2007102215

Comment 3

10 years ago
This is a rather anoying regression, it used to work fine in Sunbird 0.7. Now the user either need to restart the application or to change the sort order twice to restore the correct order.
Keywords: regression

Comment 4

9 years ago
I have this same problem, but also, when I delete tasks, the screen does not update to drop the task from the list.  If I exit the task screen by switching to the Mail or Calendar screens and then come back, it correctly shows the task list.

Comment 5

9 years ago
(In reply to comment #4)
Sounds like Bug 404039 that ought to be fixed in current 1.0pre nightly test builds already.
Keywords: qawanted

Comment 6

7 years ago
I cannot reproduce this. For me it is fixed.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.