Closed Bug 404039 Opened 12 years ago Closed 11 years ago

New added tasks don't appear in task list

Categories

(Calendar :: Tasks, defect, P1)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: martin.rohrmeier, Assigned: berend.cornelius09)

References

Details

(Keywords: dataloss)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Lightning 0.7

Once new tasks are added, they don't appear immediately in the task list. I have to change view (e.g. to Calendar, then back to Email) before the tasks appear on the list.

Reproducible: Always

Steps to Reproduce:
1.add a new task to list of tasks
2.Task doesn't appear
3.Change or update view -> task now appears
Works for me using Lightning 0.8pre (2007111604) Thunderbird 2.0.0.10pre (20071116) on Windows 2000. Tested with local storage and ics calendar.

What type of calendar do you use? Do you see any error messages in the console?
This is happening on my installation as well, exactly as described, but with the latest trunk builds. Same platform - Windows XP.   No special calendar types - just the default calendar.

Lightning 0.6a1 (2008011406) installed on Thunderbird  3.0a1pre (2008010103)
WFM using Lt 2008020902 and Thunderbird 2.0.0.9

I can confirm it for trunk build: Lt 0.6a1 2008020910 and Tb version 3.0a1pre (2008020903)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanteddataloss
Summary: new added tasks don't appear in task list → [Trunk] New added tasks don't appear in task list
Version: unspecified → Trunk
I just installed Lt 2008061519, Tbird 20080421 and see the same behavior (don't get a refresh).

I also don't get a refresh if I delete a task.
> I just installed Lt 2008061519, Tbird 20080421 and see the same behavior

Thunderbird 2.* + Lightning 0.9pre or Thunderbird 3.* + Lightning 0.6a1?
Sorry.. Tbird 2.0.0.14 (20080421) and Lightning 0.9pre (2008061519)
Flags: wanted-calendar1.0?
I can confirm this issue on latest comm-central builds: adding tasks via today pane or task mode doesn't show up immediately.
Flags: wanted-calendar1.0? → blocking-calendar1.0+
Flags: tb-integration?
toggling the show/hide completed task checkbox makes new tasks appear. 

This is one of those "initial experience" bugs that look bad.
Blocks: 461234
The thing is that the observer isn't called anymore. The only property of the observer that get's loaded is the queryinterface. Afterwards it isn't called at all. The filters are working, because they call a refresh function that isn't concerned of the observer. The problem can't be the calendar tree code itself as the last modifications were working without a problem.
Maybe the queryinterface breaks "magically", opening the task or event tab raises an error of the kind:
JavaScript error: , line 0: uncaught exception: [Exception... "Component
returned failure code: 0x80004002 (NS_NOINTERFACE)
[nsISupports.QueryInterface]"  nsresult: "0x80004002 (NS_NOINTERFACE)" 
location: "native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0"  data:
no]
Possible things are modifications on the addObserver methods or changes in xbl itself. 
It doesn't work for me on linux, so I think that this is a multi platform problem.
It isn't a problem in the "our" code, even reverting the comm-central repo to the 15.oct doesn't get this bug away for me.
(In reply to comment #9)
> JavaScript error: , line 0: uncaught exception: [Exception... "Component
> returned failure code: 0x80004002 (NS_NOINTERFACE)
> [nsISupports.QueryInterface]"  nsresult: "0x80004002 (NS_NOINTERFACE)" 
> location: "native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0"  data:
> no]

See Calendar Bug 459731 -> Core Bug Bug 459790.
Flags: tb-integration? → tb-integration+
Priority: -- → P1
Seems to be fixed by Bug 463282 (on Win) but I can still reproduce it on Mac hmm
Assignee: nobody → Berend.Cornelius
Blocks: 466095
Status: NEW → ASSIGNED
Summary: [Trunk] New added tasks don't appear in task list → New added tasks don't appear in task list
This seems fixed (on Mac) with builds from the 7th, probably by bug 460266 ?
in reply to comment #13
I think so, too
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → 1.0
I checked this on Windows and Linux and this bug is fixed -> VERIFIED
Status: RESOLVED → VERIFIED
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.