Closed Bug 407780 Opened 15 years ago Closed 15 years ago

to reduce "update fatigue" don't prompt users at all unless they haven't restarted in 24 hours

Categories

(Toolkit :: Application Update, defect, P1)

defect

Tracking

()

RESOLVED DUPLICATE of bug 391598

People

(Reporter: moco, Unassigned)

References

Details

to reduce "update fatigue" don't prompt users at all unless they haven't restarted in 48 hours

if you have "automatically download and install the update" enabled (and you don't have incompatible addons or if the user has disabled warn me about incompatible addons), we shouldn't prompt at all.

in some other bugs, there was concern about silently updating software on the users machine without any sort of notification.  we do allow the user to "opt out" of this behaviour, by checking "ask me what I want to do" 

schrep writes:

Personally I don't think we should prompt unless they haven't restarted for quite a while and otherwise install on next restart. This was funny though...

beltzner writes:

I think we need to go further than that, actually, and only alert the user to the availability of an update if they haven't restarted the browser in 48hrs. That maintains our update window, and drastically reduces the amount of prompting. 

see also bug #407536
Flags: blocking-firefox3?
Blocks: 391598
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
Summary: to reduce "update fatigue" don't prompt users at all unless they haven't restarted in 48 hours → to reduce "update fatigue" don't prompt users at all unless they haven't restarted in 24 hours
Priority: P2 → P1
No longer blocks: 391598
Depends on: 391598
this bug is kind of all over the place, but most of my original comment will be address bug dao's fix for bug #391598 (as gavin points out.)

perhaps this should be marked a dup?
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 391598
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.