Closed Bug 407808 Opened 12 years ago Closed 12 years ago

[Task Mode] quick-add field shrinks to a few pixel height and is not operable

Categories

(Calendar :: Tasks, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: sipaq)

Details

Attachments

(3 files, 2 obsolete files)

Lightning 0.8pre (2007121012) with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.12pre) Gecko/2007121004 Thunderbird/2.0.0.12pre

Followup for Bug 405127 Comment #9:

If you move the splitter below the task list to the top the edit field shrinks to a few pixel height. I see no way to restore the correct height therefore the edit field can't be used anymore. 

There probably should be a min-height set to the edit field and the task list, similar to the unifinder.

Steps to reproduce:
1. Start Thunderbird with clean profile and install Lightning.
2. Switch to Task Mode
3. Drag the splitter between the task list and the description field several times to the top and back
Flags: wanted-calendar0.8?
Attached patch Patch (obsolete) — Splinter Review
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
Attachment #299761 - Flags: review?
Flags: wanted-calendar0.8? → wanted-calendar0.8+
OS: Windows 2000 → All
Hardware: PC → All
Version: Mozilla 1.8 Branch → unspecified
Attachment #299761 - Flags: review? → review?(philipp)
Comment on attachment 299761 [details] [diff] [review]
Patch

I don't know if this is the way to go. While I was able to temporarily reproduce this, it only happened after a minute of moving the splitter up and down.

Your patch makes the quickadd field be taller than a textbox usually is. Is this intended? I don't think it should be this way.

r- for now, since I don't think the solution is ideal and it was very hard for me to reproduce. Sorry for the late review though.
Attachment #299761 - Flags: review?(philipp) → review-
Attached patch Patch v2 (obsolete) — Splinter Review
Updated patch based on your review comments and our phone discussion
Attachment #299761 - Attachment is obsolete: true
Attachment #301140 - Flags: review?(philipp)
On my WinXP the patch achieves the following:

- the task list can no longer be minimized to a height of less than four lines
- the quick-add field no longer shrinks and keeps it height at all times
Attached image Screenshot linux
Simon, unfortunately your patch doesnt fix this on linux.
Comment on attachment 301140 [details] [diff] [review]
Patch v2

minussed via comment 5.
Attachment #301140 - Flags: review?(philipp) → review-
After discussion with Philipp we went a different route with this patch.

r=philipp via IRC
Attachment #301140 - Attachment is obsolete: true
Attachment #301353 - Flags: review+
Patch v3 checked in on HEAD and MOZILLA_1_8_BRANCH.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.8
Checked in lightning build 2008020618 -> task is fixed and verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.