Import of mail from Outlook 2003 fails completely

VERIFIED FIXED in Thunderbird 3.0b1

Status

Thunderbird
Migration
P3
critical
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: Bob Riley, Assigned: Siva)

Tracking

({regression})

Trunk
Thunderbird 3.0b1
x86
Windows XP
regression
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Eudora 8.0.0b2

I used the <tools-import mail>, then in the next screen, selected Outlook, then <next> and the import started.  I couldn't read anything that was in any of the folder.  No messages were listed.  Nor did the import program ask me which .pst file to import from (that is important, since I have several, only one of which was current).

Reproducible: Always

Steps to Reproduce:
1.See above
2.
3.
Actual Results:  
The folders were imported, but the messages from Outlook 2003 were not imported successfully - none of them.

Expected Results:  
The Outlook 2003 mail and folders would be successfully imported AFTER Eudora asks me which .pst file to import FROM.

?

Comment 1

10 years ago
It fails for me as well. Trying to 'Import Everything' crashes. Trying to import just the mail from Outlook fails to import any mail (though the fact that I do not have 'local folders', ie, just IMAP/MAPI might account for that). Unfortunately Outlook importing is a lower priority for us than importing from Eudora, so this will likely have to wait a while.

Would be interesting to know if you have the same problem importing using the latest Thunderbird as well.

Matt

Assignee: mozilla-bugs → gwenger
Priority: -- → P3
Target Milestone: --- → Future
Version: unspecified → Trunk

Updated

10 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 2

9 years ago
Confirming the bug on Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b5pre) Gecko/2008032302 Thunderbird/3.0a1pre ID:2008032302

Import everything crashes for me only if I select Outlook Express - bug 419597

I couldn't find version of this bug filed for Thunderbird so maybe it would be better to change the product ?

Comment 3

9 years ago
Changing product to Thunderbird, fix in Thunderbird would fix it also for the Penelope.
Severity: major → critical
Component: General → Migration
Product: Penelope → Thunderbird
QA Contact: general → migration
Target Milestone: Future → Thunderbird 3.0b1

Comment 4

9 years ago
Requesting blocking.
Flags: blocking-thunderbird3?
(Assignee)

Comment 5

9 years ago
Created attachment 344157 [details] [diff] [review]
Fixes outlook mail import

Two issues identified.
1) 'pMsg' sent to nsOutlookCompose::SendTheMessage is modified locally only and changes do not reach nsOutlookMail::ImportMailbox.
2) 'destOutputStream' is created afresh for every mail => each mail overwrites previous mail.

Attached patch addressing these issues. Import from outlook 2007 works fine with it.
Attachment #344157 - Flags: review?(neil)

Updated

9 years ago
Flags: blocking-thunderbird3? → blocking-thunderbird3+
QA Contact: migration → sivakrishna

Updated

9 years ago
Assignee: gwenger → sivakrishna
QA Contact: sivakrishna → migration

Comment 6

9 years ago
Comment on attachment 344157 [details] [diff] [review]
Fixes outlook mail import

>   if (pListen->m_location) {
>-                pListen->m_location->Clone(&pMsg);
>+                pListen->m_location->Clone(pMsg);
If only nsIMsgSendListener used an nsILocalFile instead of an nsIFile this could have been pMsg->InitWithLocalFile(pListen->m_location) to match the intent of the original nsFileSpec code. Oh well. Anyway, while you're here, can you fix the indentation on this line, it seems to be 12 spaces too many.

>-  nsresult  SendTheMessage( nsIFile *pMsg, nsMsgDeliverMode mode, nsCString &useThisCType);
>+  nsresult  SendTheMessage( nsIFile **pMsg, nsMsgDeliverMode mode, nsCString &useThisCType);
Nit: I'd prefer if this out parameter was made the last parameter. (I don't need a new review for this change, you don't have sr yet anyway.)

>+        nsCOMPtr<nsIFile>  compositionFile;
Nit: once space between > and c please. (I know, this is just moved code.)
Attachment #344157 - Flags: review?(neil) → review+

Comment 7

9 years ago
Siva, could you please attach updated patch so it could be checked in (same with Bug 455229)

Updated

9 years ago
Keywords: regression
(Assignee)

Comment 8

9 years ago
Created attachment 346009 [details] [diff] [review]
Changes as per comment #6
[Checkin: Comment 10]

Updated patch with comments from Neil. 
David, can you sr this?
Attachment #346009 - Flags: superreview?(bienvenu)

Updated

9 years ago
Attachment #346009 - Flags: superreview?(bienvenu) → superreview+

Comment 9

9 years ago
Comment on attachment 346009 [details] [diff] [review]
Changes as per comment #6
[Checkin: Comment 10]

thx for fixing this

Updated

9 years ago
Keywords: checkin-needed
Attachment #344157 - Attachment is obsolete: true
Comment on attachment 346009 [details] [diff] [review]
Changes as per comment #6
[Checkin: Comment 10]

http://hg.mozilla.org/comm-central/rev/ed3b01f09992

NB: Please, attach Hg patch in the future.
Attachment #346009 - Attachment description: Changes as per comment #6 → Changes as per comment #6 [Checkin: Comment 10]
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED

Comment 11

9 years ago
Serge: could you also checkin patch from Bug 455229 ?

Thank you Siva for the patches!

-> VERIFIED
(the wizard is little buggy comparing to the 2.0 but with Outlook as default mail client it imports properly, will file follow-up bugs later on)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b2pre) Gecko/20081105 Lightning/1.0pre Shredder/3.0b1pre
Status: RESOLVED → VERIFIED
(In reply to comment #11)
> Serge: could you also checkin patch from Bug 455229 ?

This has not been requested there (yet).
You need to log in before you can comment on or make changes to this bug.