mouseover long links causes status bar to widen, scrollbars to vanish

VERIFIED FIXED

Status

()

Core
XUL
P3
major
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Doron Rosenberg (IBM), Assigned: John Morrison)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
2000052708 - Win32/linux.

goto http://bugzilla.mozilla.org/, and mouse over the "View Bugs Already
Reported Today" link. You will see some terrible UI horkage (the reason for cc:
ben goodger) - the urlbar widget gets extended over the navigation buttons, the
scroll bar dissapears.

The reason for this is that the shown link in the status bar is longer that the
bar itself. Bugzilla links are highly prone to this.

Not sure if this is XPToolkit or XPApps or UI.
(Reporter)

Comment 1

18 years ago
*** Bug 40841 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
*** Bug 40841 has been marked as a duplicate of this bug. ***

Comment 3

18 years ago
This looks just like bug #37658 I think this comes from ben's change to
navigatorOverlay.xul
(Assignee)

Comment 4

18 years ago
a fix for this was checked in by ben
Assignee: trudelle → ben
(Assignee)

Comment 5

18 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

18 years ago
The fix was to add 'flex="1"' to xul:text in the binding for 'statusbar-panel'
(in xmlBindings.xml) if anyone wanted to know.
(Assignee)

Comment 7

18 years ago
*** Bug 40866 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

18 years ago
*** Bug 37658 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

18 years ago
.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 10

18 years ago
... and the drawback of closing early, is that people don't find this bug
when they look for an existing open bug. Duh. Taking this bug for now.
Assignee: ben → jrgm
Status: REOPENED → NEW
Summary: mouseover a link longer than status bar causes UI horkage → mouseover long links causes status bar to widen, scrollbars to vanish
(Reporter)

Comment 11

18 years ago
marking fixed
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

18 years ago
verified. thanks doron.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.