Closed Bug 408502 Opened 14 years ago Closed 14 years ago

Adding a RSS Feed cause nsGlobalWindow leak

Categories

(Firefox Graveyard :: RSS Discovery and Preview, defect, P2)

x86
Windows XP
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: cbook, Assigned: sayrer)

References

()

Details

(Keywords: memory-leak)

Attachments

(3 files)

Attached file leak.log
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;rv:1.9b2pre) Gecko/2007121517 Minefield/3.0b3pre

Steps to reproduce: 
Create a new Profile
Go to del.ico.us
Add the RSS Feed to the Bookmark Toolbar
-> leak
Flags: blocking-firefox3?
Attached file leak log
leaks a window
Assignee: nobody → sayrer
Status: NEW → ASSIGNED
Adding an RSS feed isn't a hugely common task, so this is wanted not blocking.
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3-
Summary: Adding a RSS Feed cause memory leak → Adding a RSS Feed cause nsGlobalWindow leak
Actually, this looks like potentially bad leak. The leak log indicates that two real windows (and their inner windows) are leaked, so it's not simply leaking the hidden window.

Would be great to get a leak gauge to see which windows are being leaked here.
Flags: wanted-firefox3+
Flags: blocking-firefox3-
Flags: blocking-firefox3+
Priority: -- → P2
Attached file leak log
new Leak Log with a debug build (Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.9b3pre) Gecko/2008012113 Minefield/3.0b3pre) including the fix from
Bug 412491
This is now fixed, not leaking anymore. This was maybe fixed by our other leak fixes

-> Fixed
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
verified fixed using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008032614 Minefield/3.0b5pre ID:2008032614, thanks rob
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.