Filters scan images as plain text

RESOLVED DUPLICATE of bug 37031

Status

RESOLVED DUPLICATE of bug 37031
11 years ago
11 years ago

People

(Reporter: copa-cabana, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: 20071031

Hi,
I asked myself a few why some of my incoming mails where moved to certain folders and I analyzed the content of the mail for an explanation. But the mail did not contain the words needed to filter it correctly. 

Then I looked into the source code of the mail and found the string I was looking for in it. It was casually a word that did appear in the source of the image.

I think the source code of the image should be ignored in the filters, because it is a very randomizing factor and usualy nobody wants to filter the mails by the pictures source but by the content. I hope you understand what I am trying to say. I´m using the german version of TB.

Reproducible: Always

Steps to Reproduce:
1. attach a picture to an email
2. send it to yourself
3. open the source code of the mail and select a string snippet of the source where the picture´s source is 
4. create a filter "body contains" insert your snippet
5. run filter
Actual Results:  
mail is moved to the destination folder of the filter

Expected Results:  
mail should be kept in the original folder

I appologize, if this bug has already been reported. If there is a fix to solve the problem that I can apply myself, please let me know!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 37031
You need to log in before you can comment on or make changes to this bug.