Console throw NS_ERROR_XPC_JS_THREW_STRING

RESOLVED DUPLICATE of bug 407192

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 407192
10 years ago
8 years ago

People

(Reporter: Rem-8, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2

When opening my mail account, there are console exceptions thrown:

Error: [Exception... "'Container view not found' when calling method: [nsINavHistoryResultViewer::itemChanged]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "<unknown>"  data: no]

This is seen when you log in, load mails and then, ie. click to compose new mail

Reproducible: Always

Steps to Reproduce:
1. Log in to webpage (mail) using Squirrel Mail 
2. Click INBOX
3. Click Compose mail
Actual Results:  
Błąd: [Exception... "'Container view not found' when calling method: [nsINavHistoryResultViewer::itemChanged]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "<unknown>"  data: no]

Expected Results:  
No errors thrown

about:buildconfig

Build platform
target
i686-pc-mingw32

Build tools
Compiler 	Version 	Compiler flags
cl 	14.00.50727 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
cl 	14.00.50727 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=beta --enable-optimize --disable-debug --disable-tests --enable-update-packaging --enable-official-branding
(Reporter)

Updated

10 years ago
(Reporter)

Updated

10 years ago
(Reporter)

Comment 1

10 years ago
Well, now I see it happens to all webpages

Updated

10 years ago
Component: Error Console → Places
QA Contact: error.console → places
(Reporter)

Updated

10 years ago
Component: Places → Error Console
Component: Error Console → Places
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 407192
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.