Closed Bug 407192 Opened 12 years ago Closed 12 years ago

NS_ERROR_XPC_JS_THREW_STRING error in console when dragging bookmark from URL bar to toolbar

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set

Tracking

()

VERIFIED FIXED

People

(Reporter: marcia, Unassigned)

References

Details

Seen usingMozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9b2pre) Gecko/2007120604 Minefield/3.0b2pre.

STR:
1. Drag and drop a bookmark from the URL bar to the Bookmarks toolbar.
2. Immediately receive the following error in the console:

Error: [Exception... "'Container view not found' when calling method: [nsINavHistoryResultViewer::itemInserted]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: file:///Users/marcia/Desktop/LatestTrunk/Minefield.app/Contents/MacOS/components/nsPlacesTransactionsService.js :: PCIT_doTransaction :: line 338"  data: no]
Source File: file:///Users/marcia/Desktop/LatestTrunk/Minefield.app/Contents/MacOS/components/nsPlacesTransactionsService.js
Line: 338

Tried to reproduce on Tiger and Vista, but I was unable to. Currently only seen on Leopard.
Error: [Exception... "'Container view not found' when calling method: [nsINavHistoryResultViewer::itemChanged]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: file:///opt/firefox/components/nsLivemarkService.js :: LLL_runBatched :: line 845"  data: no]
Source File: file:///opt/firefox/components/nsLivemarkService.js
Line: 845

when changing rss handler on linux on beta 2
Duplicate of this bug: 408018
I'm getting this on 10.4.11 with 2008021002 (+/-3 hours for time zone... not quite sure how that's generated):

* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'Container view not found' when calling method: [nsINavHistoryResultViewer::itemChanged]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "<unknown>"  data: no]

I had a bunch of tabs open in 2.0.0.11 with a new profile and bookmarked all to a folder.  Then migrated that profile to the current build and opened all from that folder in tabs.  I get this whenever I go to tindermerge (which was in the folder) via accel+L, enter on an open tindermerge tab.

Will try to reduce in a bit; any hints on what the error means would help (I assume there's some fundamental part of XPCOM that I know only 1/4 of)
OS: Mac OS X → All
Hardware: Macintosh → All
Summary: [10.5] NS_ERROR_XPC_JS_THREW_STRING error in console when dragging bookmark from URL bar to toolbar → NS_ERROR_XPC_JS_THREW_STRING error in console when dragging bookmark from URL bar to toolbar
patch in bug 415390.
Depends on: 415390
fixed in Bug 415390
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre)
Gecko/2008022704 Minefield/3.0b4pre and Mozilla/5.0 (Macintosh; U; Intel Mac OS
X 10.4; en-US; rv:1.9b4pre) Gecko/2008022704 Minefield/3.0b4pre
Status: RESOLVED → VERIFIED
Duplicate of this bug: 409173
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.