Last Comment Bug 409490 - Make ChatZilla optional in SeaMonkey NSIS installer
: Make ChatZilla optional in SeaMonkey NSIS installer
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Installer (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: seamonkey2.0a1
Assigned To: Vlado Valastiak [:wladow] @ Mozilla.sk
: installer
Mentors:
Depends on: 351715
Blocks: 408844
  Show dependency treegraph
 
Reported: 2007-12-21 16:08 PST by Robert Kaiser
Modified: 2008-04-18 03:53 PDT (History)
10 users (show)
kairo: blocking‑seamonkey2.0a1-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
making chatzilla optional (7.84 KB, patch)
2008-01-17 06:07 PST, Vlado Valastiak [:wladow] @ Mozilla.sk
bugzilla: review+
neil: superreview+
Details | Diff | Splinter Review
Screenshot (15.64 KB, image/gif)
2008-01-19 11:24 PST, Frank Wein [:mcsmurf]
no flags Details
making chatzilla optional v2 (12.75 KB, patch)
2008-04-13 14:41 PDT, Vlado Valastiak [:wladow] @ Mozilla.sk
bugzilla: review+
Details | Diff | Splinter Review
making chatzilla optional v2 + fixed comment (13.01 KB, patch)
2008-04-17 12:04 PDT, Vlado Valastiak [:wladow] @ Mozilla.sk
bugspam.Callek: review+
neil: superreview+
Details | Diff | Splinter Review

Description Robert Kaiser 2007-12-21 16:08:00 PST
ChatZilla currently sits in nonlocalized\extensions\ in the NSIS installer but should be optional (installed by default).
Comment 1 Robert Kaiser 2007-12-21 16:11:15 PST
ChatZilla now is isolated in extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2} in our source - if we make that installation item also install extensions/langpack-*@chatzilla.mozilla.org next to it, a major part of bug 408844 would be solved along with this.
Comment 2 Worcester12345 2008-01-15 16:58:23 PST
Can this be made selectable or NOT installed by default?
Comment 3 Robert Kaiser 2008-01-15 18:05:39 PST
This would be something nice to have for Alpha, but it surely doesn't block us from releasing a first Alpha at all.
Comment 4 Vlado Valastiak [:wladow] @ Mozilla.sk 2008-01-17 04:15:57 PST
If nice to have, let's do it ;) If nobody is working on it, I can take this. 
Comment 5 Robert Kaiser 2008-01-17 04:22:57 PST
Would be nice if you could work on this, yes. It would probably need similar work to bug 392487 where this was done for venkman.
Comment 6 Vlado Valastiak [:wladow] @ Mozilla.sk 2008-01-17 06:07:32 PST
Created attachment 297531 [details] [diff] [review]
making chatzilla optional

This is making ChatZilla optional in custom installation and installed when using standard installation. Tested on WinVista, seems to work fine.
Comment 7 Worcester12345 2008-01-18 14:23:48 PST
(In reply to comment #6)
> Created an attachment (id=297531) [details]
> making chatzilla optional
> 
> This is making ChatZilla optional in custom installation and installed when
> using standard installation. Tested on WinVista, seems to work fine.
> 

Is it possible to flip this around so it is not installed on standard installation, and available through custom? I imagine less people use this service than do use it.

Comment 8 Robert Kaiser 2008-01-18 14:36:46 PST
we want to (In reply to comment #7)
> Is it possible to flip this around so it is not installed on standard
> installation, and available through custom?

It's possible, but we want it to be installed by default.
Comment 9 :Gijs Kruitbosch 2008-01-18 14:39:51 PST
(In reply to comment #8)
> we want to (In reply to comment #7)
> > Is it possible to flip this around so it is not installed on standard
> > installation, and available through custom?
> 
> It's possible, but we want it to be installed by default.
> 

I think you should file a separate bug for that, and that that's the kind of decision that would need more input than this (which is a valid enhancement either way, and about which there can be little dispute, as opposed to the default option).

Furthermore, are there any other components which are currently off by default? Or would ChatZilla be the first?
Comment 10 Vlado Valastiak [:wladow] @ Mozilla.sk 2008-01-18 14:57:13 PST
 (In reply to comment #7)
> (In reply to comment #6)
> 
> Is it possible to flip this around so it is not installed on standard
> installation, and available through custom? I imagine less people use this
> service than do use it.
> 

My personal opinion: this is a SUITE and ChatZilla is important part of it. Making possibility to choose whether install or not in custom installation is sufficient enough. What do you think, what is the majority of SM users - those who use DOMi, Venkman or even Composer or those who do not use them. I guess the second answer is right. Should we disable those by default?


(In reply to comment #9)
> 
> Furthermore, are there any other components which are currently off by default?
> Or would ChatZilla be the first?
> 

DebugQA and Palm Sync are not installed by default in current trunk nightlies.
Comment 11 Sven Grull 2008-01-19 00:50:11 PST
(In reply to comment #10)
> My personal opinion: this is a SUITE and ChatZilla is important part of it.
> Making possibility to choose whether install or not in custom installation is
> sufficient enough. What do you think, what is the majority of SM users - those
> who use DOMi, Venkman or even Composer or those who do not use them. I guess
> the second answer is right. Should we disable those by default?

I don't think that we should disable them by default. The best solution IMHO would be that the installer remembers which components are installed and when the user updates SeaMonkey the components selected during the first installation are selected again and the others are already deselected.
On the other hand this topic will lose relevance when the automatic update is working as then only a few will download the complete install packets for updates.
Comment 12 Frank Wein [:mcsmurf] 2008-01-19 09:06:37 PST
Comment on attachment 297531 [details] [diff] [review]
making chatzilla optional

The problem is that with ChatZilla being an additional optional component, the list of optional components won't fit on the page anymore (if all components like Palm are built). The description for Venkman is no longer visible. Maybe there's some trick to use the last bit of white-space up to the horizontal line near the buttom above the Back/Next/Cancel buttons. It's not a big problem normally, but for nightly builds it is a problem. If you want to simulate building Palm extension (to test with the installer), just comment out the ${If} ${FileExists} lines for the p@m extension in custom.nsi.
r- for now...
Comment 13 Vlado Valastiak [:wladow] @ Mozilla.sk 2008-01-19 11:17:50 PST
Frank, can you post here a screenshot? As I said before, i have tested this patch before attaching it here on WinVista with default theme and all the components (in this case five including Palm) were displayed correctly.
Comment 14 Frank Wein [:mcsmurf] 2008-01-19 11:24:07 PST
Created attachment 298001 [details]
Screenshot

Below JavaScript Debugger the description is missing.
Comment 15 Frank Wein [:mcsmurf] 2008-01-19 11:25:55 PST
Err, huh, now that I look closer something else is wrong here ;). I'll check again later.
Comment 16 Vlado Valastiak [:wladow] @ Mozilla.sk 2008-01-19 13:23:11 PST
I'm out of my building machine (until monday), but something is wrong in your build according to the screenshot - venkman's description is used for palm sync extension. I will check this again on monday even with XP, but as far I remember this was displayed correctly in my build. Did you apply the patch correctly? 
Comment 17 Frank Wein [:mcsmurf] 2008-01-19 15:15:05 PST
Yes, mismerge on my side (due to another patch). Looks correct actually.
Comment 18 Worcester12345 2008-01-22 10:06:41 PST
(In reply to comment #10)
>  (In reply to comment #7)
> > (In reply to comment #6)
> > 
> > Is it possible to flip this around so it is not installed on standard
> > installation, and available through custom? I imagine less people use this
> > service than do use it.
> > 
> 
> My personal opinion: this is a SUITE and ChatZilla is important part of it.
> Making possibility to choose whether install or not in custom installation is
> sufficient enough. What do you think, what is the majority of SM users - those
> who use DOMi, Venkman or even Composer or those who do not use them. I guess
> the second answer is right. Should we disable those by default?

In a typical user installation of this sort of "suite" software, don't you think more people would use a calendar/schedule type of program before something like "Chatzilla"? Yet, the lightning extension isn't installed by default yet. I guess the mainstream use of "Chatzilla" is not really apparent.
Comment 19 Robert Kaiser 2008-01-22 11:36:21 PST
Worchester12345:
ChatZilla was always a part of the suite and installed by default, and we will not change that, esp. not because of what you "think" or "guess". You reference to Lightning/calendar has nothing to do with that, as we have no need or even possibility to chose one over the other. For one, Lightning does not support SeaMonkey at this time, for the other, nobody says we cannot include both at some point when both actually might support SeaMonkey.

For now, let's move ChatZilla from always-installed to being uncheckable in the installer but installed by default - just as it was in SeaMonkey 1.x
Comment 20 Worcester12345 2008-01-22 12:05:58 PST
OK. Baby steps are better than no steps at all. Don't want to hold up progress as long as this will get addressed in the future.
Comment 21 Vlado Valastiak [:wladow] @ Mozilla.sk 2008-03-12 09:59:53 PDT
Frank, any progress here?
Comment 22 Frank Wein [:mcsmurf] 2008-04-11 14:56:13 PDT
Comment on attachment 297531 [details] [diff] [review]
making chatzilla optional

Looks good and works fine. Sorry for the delay.
Comment 23 Justin Wood (:Callek) 2008-04-11 22:24:47 PDT
Comment on attachment 297531 [details] [diff] [review]
making chatzilla optional

This needs an sr+ from someone as well, I suggest requesting neil@httl.net

Vlado thank you of course for the patch, and for being patient here!
Comment 24 neil@parkwaycc.co.uk 2008-04-12 06:00:48 PDT
Comment on attachment 297531 [details] [diff] [review]
making chatzilla optional

Is it possible to reorder all the sections where you added ChatZilla to match each other? Currently you display ChatZilla first (which may well be the best place to put it) but the rest of the time you put it last.

Also, did you ask a ChatZilla representative for that description (CHATZILLA_TEXT)?
Comment 25 James Ross 2008-04-12 06:11:36 PDT
The text is fine by me; it's a slightly shortened version of the short description we have on https://addons.mozilla.org/en-US/firefox/addon/16.
Comment 26 Vlado Valastiak [:wladow] @ Mozilla.sk 2008-04-13 14:41:46 PDT
Created attachment 315409 [details] [diff] [review]
making chatzilla optional v2

Neil, could you take a look here again pls, if this is what you wanted. Sections are now reordered with ChatZilla on the first place. Tested on WinVista, seems to be working as expected.
Comment 27 neil@parkwaycc.co.uk 2008-04-13 16:19:58 PDT
Comment on attachment 315409 [details] [diff] [review]
making chatzilla optional v2

This looks like what I wanted but I think mcsmurf should have a chance to double-check.
Comment 28 Frank Wein [:mcsmurf] 2008-04-17 11:40:53 PDT
Comment on attachment 315409 [details] [diff] [review]
making chatzilla optional v2

>   ; If DOMi doesn't exist then debugQA will be Field 2 (when DOMI and debugQA
>   ; don't exist, palm sync will be Field 2).
>   StrCpy $R1 2
>-  ${If} ${FileExists} "$EXEDIR\optional\extensions\inspector@mozilla.org"
>+  
>+ ${If} ${FileExists} "$EXEDIR\optional\extensions\{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}"

Can you fix that comment? It's no longer correct after the reordering (now CZ would be field 2, DOMi 3 and so on). The comment does not need to cover all optional components, it's just an explanation of how the code works. Rest looks ok.
Comment 29 Vlado Valastiak [:wladow] @ Mozilla.sk 2008-04-17 12:04:27 PDT
Created attachment 316273 [details] [diff] [review]
making chatzilla optional v2 + fixed comment
Comment 30 Justin Wood (:Callek) 2008-04-17 18:36:03 PDT
Comment on attachment 316273 [details] [diff] [review]
making chatzilla optional v2 + fixed comment

The comment change here, I don't think needs another eye, Neil and mcsmurf seem to be ok with this now.

I'll checkin within 24 hours for you.
Comment 31 Justin Wood (:Callek) 2008-04-17 18:36:54 PDT
...that is if reed doesn't beat me to it.
Comment 32 :Gavin Sharp [email: gavin@gavinsharp.com] 2008-04-17 19:56:12 PDT
mozilla/suite/installer/Makefile.in 	1.10
mozilla/suite/installer/windows/nsis/custom.nsi 	1.4
mozilla/suite/installer/windows/nsis/installer.nsi 	1.9
mozilla/suite/locales/en-US/installer/windows/custom.properties 	1.6 
Comment 33 neil@parkwaycc.co.uk 2008-04-18 03:53:11 PDT
Comment on attachment 316273 [details] [diff] [review]
making chatzilla optional v2 + fixed comment

Just for the record.

Note You need to log in before you can comment on or make changes to this bug.