If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Make Firefox 3 minimum hardware system requirements more realistic and clarify wording

RESOLVED WONTFIX

Status

www.mozilla.org
General
RESOLVED WONTFIX
10 years ago
5 years ago

People

(Reporter: AndrewM, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [server side], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3pre) Gecko/2007122105 Minefield/3.0b3pre
Build Identifier: 

The Firefox 3 'Minimum Hardware' system requirements posted on the website for the Beta releases seem rather out-of-date (they are in fact the same as for Firefox 2 at the moment: http://www.mozilla.com/en-US/firefox/system-requirements.html). They should be updated to be more realistic.

On Windows, the requirements currently are:

* Pentium 233 MHz (Recommended: Pentium 500MHz or greater)
* 64 MB RAM (Recommended: 128 MB RAM or greater)
* 52 MB hard drive space

For the processor, it would probably be better to change it to 'Intel or AMD 233 MHz processor' rather than 'Pentium' (very few processors sold these days are actually called 'Pentium'). 233 MHz seems rather low but perhaps Fx 3 does run usably on that; I don't know.

The Firefox3/Firefox Requirements page on MozillaWiki (http://wiki.mozilla.org/Firefox3/Firefox_Requirements#System_Requirements) recommends 128 MB RAM and 100 MB hard drive space; this seems reasonable. (Note: The MozillaWiki page does say that 'These requirements are not final and are subject to change pending review.')

Not on the topic of minimum hardware requirements, but is Windows Server 2008 going to be officially supported? It's going to be launched on 27 February (http://en.wikipedia.org/wiki/Windows_Server_2008).

For Mac, the requirements currently are:

* Macintosh computer with an Intel x86 or PowerPC G3, G4, or G5 processor
* 128 MB RAM (Recommended: 256 MB RAM or greater)
* 200 MB hard drive space

The Firefox3/Firefox Requirements page says 256 MB RAM; this certainly sounds right for the minimum because it is the minimum required for Mac OS X 10.4 (http://docs.info.apple.com/article.html?artnum=301341). The MozillaWiki page recommends only 150 MB hard drive space, rather than the current 200 MB, which seems a bit odd.

For Linux, the requirements currently are:

* Intel Pentium II or AMD K6-III+ 233 MHz CPU (Recommended: 500MHz or greater)
* 64 MB RAM (Recommended: 128 MB RAM or greater)
* 52 MB hard drive space

Again, I would suggest changing 'Intel Pentium II or AMD K6-III+ 233 MHz CPU' to just 'Intel or AMD 233 MHz processor'; there doesn't seem to me to be any need to specify which version if you are specifying a minimum clock speed. The MozillaWiki page recommends 256 MB RAM and 100 MB hard drive space for Firefox on Linux.

Reproducible: Always
(Reporter)

Comment 1

10 years ago
Could this be looked at before release?
(Reporter)

Comment 2

10 years ago
I realize this is not worth blocking the release for; this is really a nomination for wanted-firefox3 (if that is possible for Websites).
Flags: blocking-firefox3?
Whiteboard: [server side]
Are we sure this isn't a dupe?

I don't think this is critical enough to require a localization firedrill and such, but we should fix it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3? → blocking-firefox3-
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)
> Are we sure this isn't a dupe?

There is the rather old bug 145576, filed back in 2002, which is asking to reduce the system requirements. Also, there is blocking bug 405669, but that is solely about Linux software requirements.

> I don't think this is critical enough to require a localization firedrill and
> such, but we should fix it.

Would just changing numbers still require a localization firedrill? Like the Mac RAM requirement, for instance, from 128 to 256, so that we don't end up with the rather strange situation of the system requirements for Firefox being lower than those for the OS itself ;)
Firefox 3 isn't our latest anymore.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

6 years ago
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
(Assignee)

Updated

5 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.