Safe mode option to disable all add-ons doesn't disable plugins

RESOLVED FIXED in Firefox 3.1a1

Status

()

defect
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: mossop, Assigned: mossop)

Tracking

(Blocks 1 bug)

Trunk
Firefox 3.1a1
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

When you start safe mode you get a checkbox that you can tick to disable all your add-ons and they are then disabled when starting normally. Plugins aren't affected by this.
Flags: blocking-firefox3?
I suggest something like this:

Firefox Safe Mode
-------------------------------------------------------------------------

Firefox is now running in Safe Mode, which temporarily disables your custom settings, themes and extensions
-------------------------------------------------------------------------
You can make some or all of these changes permanent:

- Disable all extensions
- Use default theme
- Disable all plug-ins
- Reset toolbars and controls
- Reset bookmarks to Firefox default 
- Reset al user preferences to Firefox defaults
- Restore default search engines
(In reply to comment #2)
> Isn't this a dupe of bug 342333?

No, that talks about having plugins disabled only while in safe mode if you restart to normal mode the plugins would be enabled again, the same as happens with extensions normally. This is about the checkbox that is used to permanently disable all add-ons.
This does not block the final release of Firefox 3.
Flags: blocking-firefox3? → blocking-firefox3-
Posted patch patch rev 1Splinter Review
Simple patch that disables all plugins at the same time as the other add-ons. Since the checkbox is already labelled "Disable all add-ons" I think the expectation would be that everything in Tools - Add-ons gets disabled.

Had to add the check to the pref clear since it was throwing an exception when the default theme was already selected.
Assignee: nobody → dtownsend
Status: NEW → ASSIGNED
Attachment #328458 - Flags: review?(gavin.sharp)
Attachment #328458 - Flags: review?(gavin.sharp) → review+
Landed in changeset d969f2a04e3c.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1a1
You need to log in before you can comment on or make changes to this bug.