yahoo.co.jp - redirects all non-"Firefox 2.0" (exact match) Gecko browsers to a downgraded page

VERIFIED FIXED

Status

VERIFIED FIXED
11 years ago
4 years ago

People

(Reporter: phiw2, Assigned: kev)

Tracking

({top100})

Details

(URL)

(Reporter)

Description

11 years ago
Redirects all Gecko browsers that are not Firefox 2.0 (exact match [*]) to a more minimal page.
Since 2008.1.1, when they 'upgraded' the front page to something similar to yahoo.com.

[*] That includes Camino 1.5, Camino-with-Firefox-in-the-UA-string (1.6a 2.0a), Minefield, Bonecho, SeaMonkey.
See also bug 410430.
Keywords: top100
(I should say, these bugs are separate. yahoo.com still works fine with 2007 browsers including Camino 1.5.4.)
Blocks: 121228
Summary: yahoo.co.jp → yahoo.co.jp - redirects all non-"Firefox 2.0" (exact match) Gecko browsers to a downgraded page
(Assignee)

Comment 3

11 years ago
Adding Kohei to this thread, as he and Gen work regularly with the folks at yahoo.jp on Firefox builds we create for them.
Note that yahoo.co.jp and yahoo.com are not same company.

I think that similar issue is occurred in some sites. I think that we need to evangelize that "Gecko" should be checked in UA string, not "Firefox".
No, "Gecko/" should be checked (Safari sucks).
Here is a good document for appropriate browser detection.
http://developer.mozilla.org/en/docs/Browser_Detection_and_Cross_Browser_Support
(Reporter)

Comment 6

11 years ago
Well, as of 4 minutes ago (Jan 4, 13:40, Japan time), we were able to access the full page, no apparent redirect anymore.
When my partner checked Yahoo.co.jp today around 10:00 Japan Time, that was not yet the case.
Tested with Camino 1.5.4, Camino 2.0a1pre trunk build and Minefield trunk.

Leaving this bug open, to make sure it was not a temporary error :-).

Comment 7

11 years ago
cannot reproduce with SeaMonkey/2008010203-trunk/WinXP, 
Firefox/2008010304-trunk/WinXP, too.

Updated

11 years ago
Assignee: japanese → kev

Comment 8

11 years ago
Works for me too with trunk/linux.
Marking WFM.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2008020120 
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
FIXED, actually, since this is a TE bug.
Resolution: WORKSFORME → FIXED
Yep, this appears to be FIXED, v. with Camino's latest trunk (with and without the "like Firefox" bit in its UA string).
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.