"Check for new messages at startup" ignored for some POP accounts, manual "check all" fails with no error.

RESOLVED WORKSFORME

Status

Thunderbird
Account Manager
--
major
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Erik Harris, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: version 2.0.0.9 (20071031)

My wife and I both converted from Eudora 4.3.2 to Thunderbird 2.0.0.9, and both of us are experiencing these same symptoms.  I've got four email accounts set up in Thunderbird, and she has three.  When I start Thunderbird, some or all of my non-Default accounts will check for mail, but the "Default" account (to which the majority of my email comes) does NOT check for mail.  If I manually poll all accounts for messages, it still does not check.  If I _specifically_ tell Thunderbird to check that account only, it retrieves all of the mail.  Alternately, if I wait until the next timed mail check ("Check for new messages every __ minutes"), it successfully checks the account.  No error message or any other kind of feedback is provided by the program to indicate what it did or did not do.

It may or may not be worth noting that both of us have our default accounts set up to dump all mail into the "Local Folders" mailboxes, and do not have separate mailboxes.

Needless to say, it's a bit annoying opening Thunderbird and having to manually check my primary email account or having to wait 5-10 minutes for it to check my mail for me.

This seems to happen every time I open Thunderbird, but I cannot say for certain that it's every single time and not just most of the time, since Thunderbird fails to give me any kind of server status info (it doesn't tell me which servers it's polling and at what step in the process it is, like Eudora kindly does).  Because of the lack of server status info, I also can't say for certain that it's checking all three other accounts, since I don't get mail to them as frequently.  If no mail comes in, it could because there's no new mail, because Thunderbird didn't check the account, or both.

Reproducible: Always

Steps to Reproduce:
1. Install Thunderbird
2. Import multiple accounts from Eudora 4.3.2 (don't know if this step is necessary)
3. Start Thunderbird
Actual Results:  
Some accounts check, primary/Default account does not get checked.

Expected Results:  
Accounts should be checked, new messages should appear.

All accounts have "Check for new messages at startup," "check for messages every __ minutes," and "Automatically download new messages" checked.  All mail accounts  have "Fetch headers only," and "Leave messages on server" UNchecked.  Accounts are set to check without secure authentication, but to use "TLS, if available."
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0

Comment 1

9 years ago
global inbox?
or separate folder for each account?
(Reporter)

Comment 2

9 years ago
I have not seen recurrence of this bug in months.  I don't know if one of the interim updates solved this, or some aspect of our configurations changed.
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.