[BC] borders touching edge of overflow area are cut when overflow isn't visible

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

({testcase})

Trunk
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

1.06 KB, text/html
Details
3.23 KB, patch
bzbarsky
: review+
bzbarsky
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

After constructing a scrolling table which is placed within a <div style="overflow:auto;...", the most left border of the td tags does not show up. The complete left border of the scrolling area is overdrawn by line of 1px (in background color).
The effect does not appear, if no DOCTYPE is given. The effect also does not appear for HTML 4.01, when no attribute for dtd is given. 
IE 6 and Opera 9 do not show this problem.

Reproducible: Always

Steps to Reproduce:
1. download html attachment
2 [review]. open attachment in Firefox
3. change DOCTYPE of html according to the included comments
4. Change border-left to 3px in order to see the overdrawing line on left border
Actual Results:  
There is no visible left border in the table.

Expected Results:  
There should be a 1 px line in color magenta on the left.

See sample code in attachment Left-TR-border-bug.html.
(Reporter)

Comment 1

12 years ago
Posted file Sample html page code (obsolete) —
(Reporter)

Updated

12 years ago
Version: unspecified → 2.0 Branch
(Reporter)

Updated

11 years ago
Severity: normal → critical

Comment 2

11 years ago
I'll add a reduced testcase shortly.

All right. An element which has its overflow property set to anything but 'visible' that contains a table which has border-collapse set to 'collapse' cuts parts of the top and left border (of the table) when these are touching the edge of the overflow area.

It is visible on branch and on trunk, but never in Quirks Mode.

It's only the left and top borders that may get cut, even in RTL mode.
Severity: critical → normal
Status: UNCONFIRMED → NEW
Component: General → Layout: Tables
Ever confirmed: true
OS: Windows XP → All
Product: Firefox → Core
QA Contact: general → layout.tables
Hardware: PC → All
Summary: Left Border not displayed in div with overflow, depending on DOCTYPE → [BC] borders touching edge of overflow area are cut when overflow isn't visible
Version: 2.0 Branch → Trunk

Comment 3

11 years ago
Posted file reduced testcase
Attachment #295216 - Attachment is obsolete: true

Updated

11 years ago
Duplicate of this bug: 403486

Updated

11 years ago
Duplicate of this bug: 451192
Sounds like the table doesn't include its borders in its overflow area.  It probably should.

Updated

11 years ago
Keywords: testcase
(Reporter)

Comment 7

11 years ago
Daniel's reduced test case also shows an additional horizontal scrollbar (on my linux system), that should not be there. Probably there is a problem with computing the width of the GUI's scrollbar that gives the table also an offset to the left. Part of the line seems to be hidden under the div.
The reduced test case also shows a strange behaviour, if you zoom in with Ctrl-Mousewheel. The most left line sometime gets thinner while everything else is getting larger.

Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0.1) Gecko/2008070400 SUSE/3.0.1-1.1 Firefox/3.0.1
Running on SuSE 10.3/KDE 3.5

Comment 8

11 years ago
thats the border area that triggers an overflow area outside of the table

Comment 9

10 years ago
This has been fixed by Bug 155955.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Depends on: 155955
Resolution: --- → FIXED
Can we add a reftest?
Flags: in-testsuite?

Comment 11

10 years ago
Posted patch reftestSplinter Review
This is almost the same as the testcase. Fails in builds before Bug 155955 was fixed and passes after (trunk).
Attachment #362222 - Flags: superreview?(bzbarsky)
Attachment #362222 - Flags: review?(bzbarsky)
Attachment #362222 - Flags: superreview?(bzbarsky)
Attachment #362222 - Flags: superreview+
Attachment #362222 - Flags: review?(bzbarsky)
Attachment #362222 - Flags: review+
Pushed test as http://hg.mozilla.org/mozilla-central/rev/3d0096fb2c41 and http://hg.mozilla.org/mozilla-central/rev/cf1bbf012e85

Thank you for doing that, Daniel!
Flags: in-testsuite? → in-testsuite+

Updated

10 years ago
Duplicate of this bug: 489279
You need to log in before you can comment on or make changes to this bug.