If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

table with border-collapse: collapse; losses 1px of left and top borders in container with overflow: hidden

RESOLVED DUPLICATE of bug 410621

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 410621
9 years ago
9 years ago

People

(Reporter: Alex, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

FireFox does not show top and left border of the table with border-collapse: collapse; when it is in container with overflow: hidden; and border width 1px and does not display 1px of top, bottom and left borders when border width 2px.

Reproducible: Always

Steps to Reproduce:
Open this HTML in FireFox 3.0.1:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="content-type" content="text/html; charset=utf-8" />
<title>Page</title>
<style type="text/css">
div { overflow: hidden; }
.sample1 table, .sample1 td { border: solid 1px red; border-collapse: collapse; }
.sample2 table, .sample2 td { border: solid 2px red; border-collapse: collapse; }
</style>
</head>
<body>

<div class="sample1">
	<table>
		<tr><td>1</td><td>2</td></tr>
		<tr><td>3</td><td>4</td></tr>
	</table>
</div>

<br/>

<div class="sample2">
	<table>
		<tr><td>1</td><td>2</td></tr>
		<tr><td>3</td><td>4</td></tr>
	</table>
</div>

</body>
</html>
Actual Results:  
First table has no top and left borders.
Second table has not 1px of top, bottom and left borders.

Expected Results:  
First table has 1px border.
Second table has 2px border.


Opera 9.5, Safari for Windows and IE displays sample page correctly.
Both FF2 and FF3 have this bug.
(Reporter)

Comment 1

9 years ago
Workaround: marging: 1px; for the tables.

Comment 2

9 years ago
Thanks for your report, however, this bug is already filed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 410621
You need to log in before you can comment on or make changes to this bug.