Cannot finish setup for Lightning/Google Calendar

RESOLVED DUPLICATE of bug 408367

Status

Calendar
Provider: GData
RESOLVED DUPLICATE of bug 408367
10 years ago
10 years ago

People

(Reporter: Michael, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

OS: Fedora 8
Thunderbird: 2.0.0.9
Lightning: 0.7
Provider for Google Calendar: 0.3.1

I run through the steps to add a new calendar, using the Google Calendar address. I add a name and color, and press Next...yet nothing happens.

Error Console reports two errors:

Error: [Exception... "Invalid ClassID or ContractID"  nsresult: "0x80570017 (NS_ERROR_XPC_BAD_CID)"  location: "JS frame :: file:///home/mmarino/.thunderbird/81gq8aec.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js :: initBaseComponent :: line 67"  data: no]
Source File: file:///home/mmarino/.thunderbird/81gq8aec.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js
Line: 67

Error: [Exception... "ServiceManager::GetService returned failure code:"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://calendar/content/calUtils.js :: getCalendarManager :: line 82"  data: no]
Source File: chrome://calendar/content/calUtils.js
Line: 82

Reproducible: Always

Steps to Reproduce:
1. Install Lightning and Provider for Google Extensions for Thunderbird
2. Add new calendar on the network
3. Select Google Calendar and copy XML address
4. Type Name and select color
5. Press Next
Actual Results:  
Nothing. I press next and nothing happens. I can go back and change settings, but once I get to the name/color screen, pressing Next does nothing.

Expected Results:  
Finishing the setup, entering password, creating calendar sync.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 383436

Comment 2

10 years ago
Try installing libstdc++5 via the package "compat-libstdc++" and test again. This helped on some systems. Otherwise try switching to an official mozilla.org Thunderbird build.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

10 years ago
Installing compat-libstdc++-33 worked. Thank you for the suggestions.

Updated

10 years ago
Status: VERIFIED → RESOLVED
Last Resolved: 10 years ago10 years ago
Duplicate of bug: 408367
You need to log in before you can comment on or make changes to this bug.