Problems on Linux distributions (Can't add calendar/tasks/events) - libstdc++5 needed

VERIFIED INVALID

Status

Calendar
Lightning Only
--
critical
VERIFIED INVALID
10 years ago
8 years ago

People

(Reporter: Marco, Unassigned)

Tracking

Details

(Whiteboard: see comment 11 before commenting in the bug, URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.8.1.10) Gecko/20071128 Fedora/2.0.0.10-2.fc8 Firefox/2.0.0.10
Build Identifier: Fedora 8 2.6.23.8-63.fc8 - Thunderbird 2.0.0.9 - Lighning 0.7

When you try to add calendare Lightning stop the wizard and you cannot use it without a calendar.

Reproducible: Always

Steps to Reproduce:
1.Thunderbird
2.Add calendar
3.Insert calendar name 
Actual Results:  
and the wizard stop and you can only abort it.

Expected Results:  
Add a calendar

about:buildconfig

Build platform
target
i686-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 4.1.2 20070925 (Red Hat 4.1.2-33) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long -pedantic -pthread -pipe
c++ 	gcc version 4.1.2 20070925 (Red Hat 4.1.2-33) 	-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic -fshort-wchar -pthread -pipe

Configure arguments
--enable-application=browser --prefix=/usr --libdir=/usr/lib --with-system-nspr --with-system-nss --with-system-jpeg --with-system-zlib --with-system-png --with-pthreads --disable-tests --disable-debug --disable-installer '--enable-optimize=-Os -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables' --enable-xinerama --enable-default-toolkit=gtk2 --disable-xprint --disable-strip --enable-pango --enable-system-cairo --enable-svg --enable-canvas --enable-startup-notification --enable-official-branding
Did you build Lightning yourself? Or are you trying to use the official Lightning package from mozilla.org with your custom Thunderbird build? In the latter case you need to build your own Lightning matching your Thunderbird build.

Also check if the System Requirements are fulfilled. For example many systems seems to lack libstdc++5 <http://www.mozilla.org/projects/calendar/sunbird/system-requirements.html>

I'd like you to remind that Bugzilla is a bug reporting tool and not a support forum. Please also check the support forum and newsgroup regarding Fedora 8, e.g.
<http://forums.mozillazine.org/viewforum.php?f=46>
<http://groups.google.com/group/mozilla.support.calendar>
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> Did you build Lightning yourself? Or are you trying to use the official
> Lightning package from mozilla.org with your custom Thunderbird build?
The latter case.
> 
> Also check if the System Requirements are fulfilled. For example many systems
> seems to lack libstdc++5
 
True in Fedora 8 libstdc++ is 4.1.2-33. I suppose this could be the problem.

> I'd like you to remind that Bugzilla is a bug reporting tool and not a support
> forum. 

Ok, sorry for it. 

Thx
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

10 years ago
Status: RESOLVED → VERIFIED
Summary: Cannot add calendar. → Problems on Linux distributions (Can't add calendar/tasks/events)

Updated

10 years ago
Duplicate of this bug: 400337

Updated

10 years ago
Duplicate of this bug: 411191

Updated

10 years ago
Duplicate of this bug: 404479

Updated

10 years ago
Duplicate of this bug: 395611

Updated

10 years ago
Duplicate of this bug: 391801

Updated

10 years ago
Duplicate of this bug: 427430

Updated

10 years ago
Duplicate of this bug: 427432

Updated

10 years ago
Summary: Problems on Linux distributions (Can't add calendar/tasks/events) → Problems on Linux distributions (Can't add calendar/tasks/events) - libstdc++5 needed

Comment 10

10 years ago
This Bug is always there in the official lightning 0.8 linux version. I use ubuntu 7.10 with 2.6.22-14 Kernel. And an official ubuntu Thunderbird Version 2.0.0.12 (20080227).
Marcus, this is no bug on our side (that's the reason the bug is marked INVALID).

Ubuntu (and other distributions) just do not install the packages required for Lightning in their default configuration. 

So if you want to use Lightning, either install the required packages (see URL line here in the bug) or wait until Ubuntu updates its Lightning package for 0.8

Updated

10 years ago
Whiteboard: see comment 11 before commenting in the bug

Comment 12

10 years ago
I Think its an Bug because i've installed all requirements from the link on Top.
So we should open it again
Just adding my 2 cents: It also has something good to stick with older (e.g. libstdc++.5) baselines, because there are quite some users out there that still run these older systems, and it's usually no problem to install the necessary compat packages on newer systems.

Comment 14

10 years ago
There is no option for me to downgrade to an older baseline, because the 0.8 calendar is not compatible with older versions. I Think it an Bug, because sunbird 0.8 runs. But i don't want an debate on principles. My Opinion is, thats an bug, because Tasks and Event Creation is an main Topic of an Calendar. Can anyone also reproduce this bug?
Marcus, do prevent any unresolved packages dependencies you can uninstall the lightning.xpi from mozilla.org and install the lightning-extension package from the Ubuntu repositories instead.
... or sudo apt-get install libstdc++5

Comment 17

10 years ago
The libstdc++5 is the newest version and in the repositories is only 0.5 of lightning/sunbird. So i take the xpi file until the repositories is updates.
Marcus, thunderbird/lightning runs without problems on my ubuntu 7.10. Please cd into ~/.mozilla-thunderbird/<profile-dir>/extensions/*e2*/components and ldd lib*.so. Check if there are unresolved libraries, except for the mozilla ones libxpcom*.so and libmozjs.so.

Comment 19

10 years ago
Daniel,i found some unsolved dependencies. But all! Files are installed on my system. So i tested it with the nightly build from today(Version 2008070404) the 0.9pre. And whant a wonder it runs normally. In this time i don't no why, but with the 0.9 Version of lightning you can add Calendars and Tasks like in MS Windows. OS.
And with the 0.9 the dependencies also unresolved.
Marcus, I would verify your downloaded 0.8; I suspect it's rotten. There's hardly any difference to 0.9pre.
I remember comments from the forum and newsgroup that you need to install libstdc++5 *before* installing Lightning to make it work. Maybe you installed libstdc++5 after Lightning and therefore it didn't work. A simple reinstall fixed it.
Right, that's indeed necessary since registering native xpcom components requires to load them, which would have failed at that time (because of the unresolved libstdc++5).

Comment 23

10 years ago
Yeah it runs Thanks a lot.
I know many things of programming and my Computer, but in the Requirements there are no information that i have to setup the system before.
I would propose the following sentence on the requirements page: Please make sure that you meet all requirements before installing the new lightning.

Comment 24

10 years ago
Yeah it runs Thanks a lot.
I know many things of programming and my Computer, but in the Requirements there are no information that i have to setup the system before.
I would propose the following sentence on the requirements page: Please make sure that you meet all requirements before installing the new lightning.
Duplicate of this bug: 428635
Duplicate of this bug: 427415
Duplicate of this bug: 429081
Just a thought .. but have you installed 

compat-libstdc++-296.i386                2.96-139               fedora          
compat-libstdc++-33.i386                 3.2.3-62               fedora 

It fixed an issue with my FC8 where Lightning would not even come up .. 

Updated

10 years ago
Duplicate of this bug: 435769

Comment 30

10 years ago
Since this bug seems to have a lot of duplicates, can we put this in the FAQ? There is absolutely no mention that libstdc++5 is necessary and no error message that this is the cause of this failure (the only reason I found out about this fix was because I checked the bugtracker). Also, how feasible would it be for Lightning to check the presence of libstdc++5 during installation?

(In reply to comment #30)
> There is absolutely no mention that libstdc++5 is necessary

Wrong. See <http://www.mozilla.org/projects/calendar/lightning/system-requirements.html#linux>
Duplicate of this bug: 460972
Duplicate of this bug: 463218

Comment 34

9 years ago
I think because Lightning is silently eating exceptions, this is a bug. It should at least complain about missing dependencies, if possible. Clearly, the exception is there -- it should bubble up to the user OR, at a minimum, have a more obvious error message in the exception.

Updated

9 years ago
Duplicate of this bug: 471735

Updated

9 years ago
Duplicate of this bug: 475670

Updated

9 years ago
Duplicate of this bug: 475952
Duplicate of this bug: 485081
Duplicate of this bug: 526617

Comment 40

8 years ago
I found "lightning-extension" in the Ubuntu repository, installed it and now my calendars work perfectly.  I had been trying to install from the download from Mozilla.com.  It does not work with Ubuntu Thunderbird.  Great, now we have distro-specific apps.  I don't know if that's good or bad.  It's good that Ubuntu fixed Lightning for its distro, though!
Thanks for posting all this information.  It led me to the right place.
-Alex
Duplicate of this bug: 528738

Comment 42

8 years ago
Stefan! Get off your high horse and think for a minute.
It is a bug as libstd++5 in obsolete and has been kicked off the repositories, so if lightning ask for something that doesn't exist, it's BUGGED!

Workaround..

Don't use Thunderbird's tools>add-ons to install lightning.

Go to the Synaptic Package Manager and click on lightning instead.
This will automatically load the following:
calendar-timezones
calendar-google-provider
Hey Presto!

Now how about updating lightning?
Alistair, libstdc++5 has only recently been removed, in ubuntu 9.10. I agree its not the best solution to have to download this package from an older ubuntu repository, but right now thats the only way to go.

Due to our small team size, we don't have enough resources to do additional releases on the mozilla 1.8 platform (0.9 release). We are focusing on the new 1.9.1 platform (1.0b1 release) and I assure you we will look into this again for our beta. Believe me, back in times of the 0.9 release we tried many things to try to get rid of this dependency, but we never quite identified why this dependency is in place. If it were as easy as you make it sound, then we would have done this in no time.

Thanks for bearing with us!

Comment 44

8 years ago
Upon the install of v3 of Thunderbird 

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.5) Gecko/20091209 Fedora/3.0-3.fc11 Lightning/1.0pre Thunderbird/3.0

lightning has been disabled, although it is shown as enabled, and can't be re-enabled. On boot of TB I get the following error:

Error code: 0x80004005

Description: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [mozIStorageStatement.reset]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///usr/lib/thunderbird-3.0/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calStorageUpgrade.jsm :: ensureUpdatedTimezones :: line 380"  data: no]
(In reply to comment #44)
Jon, please have a look at bug 529853!
You need to log in before you can comment on or make changes to this bug.