Last Comment Bug 411428 - Redesign Socorro reporter to be more user-friendly
: Redesign Socorro reporter to be more user-friendly
Status: RESOLVED DUPLICATE of bug 539742
:
Product: Socorro
Classification: Server Software
Component: General (show other bugs)
: Trunk
: All All
: P1 normal (vote)
: 0.6
Assigned To: Nobody; OK to take it and work on it
: socorro
:
Mentors:
http://code.google.com/p/socorro/issu...
Depends on: 456402 465659 465660
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-08 18:31 PST by Samuel Sidler (old account; do not CC)
Modified: 2011-12-28 10:40 PST (History)
10 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
New version of the header global nav (26.92 KB, image/png)
2009-06-24 12:01 PDT, Neil Lee [:neilio]
no flags Details
Various states of the new global nav (118.25 KB, image/png)
2009-07-07 13:02 PDT, Neil Lee [:neilio]
no flags Details
Screenshot of the new nav in context (on top of a Camino crash signature) (218.59 KB, image/png)
2009-07-07 13:03 PDT, Neil Lee [:neilio]
no flags Details

Description Samuel Sidler (old account; do not CC) 2008-01-08 18:31:20 PST
Reported by samuel.sidler, Dec 06, 2007

Ted said the design sucks in IE6. I'll investigate and come up with a fix.
Comment 1 Samuel Sidler (old account; do not CC) 2008-01-09 21:17:27 PST
The redesign I'm working on looks good in IE6 and IE7 but some spacing is off. Not enough to care about. If we accept it, it'll fix this bug. What do ya'll think?

http://people.mozilla.com/~ss/socorro-redesign/

(Courtesy Stephen)
http://img156.imageshack.us/my.php?image=picture1it4.png
http://img265.imageshack.us/my.php?image=picture2fq4.png
http://img265.imageshack.us/my.php?image=picture3vi9.png
Comment 2 Samuel Sidler (old account; do not CC) 2008-01-09 23:57:15 PST
Comments so far about the design:

  * beltzner thinks the default topcrash view should have data in it.
    He recommended the topcrash data from the latest Firefox release.
    I disagree because it's a waste of download for some users and it's
    unclear which "release" we'd show: trunk or branch.
  * morgamic wondered why the blue bar at the top. Basically I added it
    to give the page some color and design. It's something I want to
    use on other redesigns I'm working on. It can go, but I think it's
    nice.
  * morgamic also wondered why I removed the date picker. "Oops." I'll
    add that back.
  * And finally, morgamic said the topcrashers page was too tab-happy
    and to just make it a list again. My argument against that is when
    all products have releases on it, the page will be long and hard
    to find things. Sorting by product makes sense here.
Comment 3 Michael Morgan [:morgamic] 2008-11-03 11:06:22 PST
Neil will be taking a look at this and responsible for a full reskin.
Comment 4 Neil Lee [:neilio] 2008-11-04 07:21:55 PST
Is there somewhere I could see / download / etc. searches that have been done, so I can see how people are using search and what criteria are the most, er, popular?
Comment 5 Michael Morgan [:morgamic] 2008-11-04 08:21:26 PST
Filed bug 463053 to get some logs parsed.  We forgot/failed to set up the urchin utm.js but we should be able to posthumously set it up or just quickly add it so we can get stats from the next few days.
Comment 6 Austin King [:ozten] 2009-03-31 10:23:37 PDT
Another navigation requirement.

Reports are (mostly) available in CSV as an alternative. This should be a standard part of the nav/page design.

Example:
http://crash-stats.mozilla.com/topcrasher/byversion/Firefox/3.0.9pre
Actual:
Want to slice and dice? CSV Formatted Raw Data

Expected:
More integrated into navigation (icon or something)
Comment 7 Michael Morgan [:morgamic] 2009-04-23 14:50:44 PDT
Note: restore the UUID lookup -- not everyone comes in from about:crashes
Comment 8 Neil Lee [:neilio] 2009-06-12 13:57:51 PDT
Can I get some comments on this rejigged header navigation, please? Does this address some of the issues people have raised?

http://snaps.beatnikpad.com/socorro-header-20090612-164550.png

The topcrasher link could link to something similar to this, but with a more specific product emphasis (the top 10 lists at the top would be replaced with latest nightly, release, beta, etc.).

http://blog.mozilla.com/webdev/files/2008/12/topcrashers-full.png
Comment 9 Samuel Sidler (old account; do not CC) 2009-06-12 14:42:32 PDT
(In reply to comment #8)
> Can I get some comments on this rejigged header navigation, please? Does this
> address some of the issues people have raised?
> 
> http://snaps.beatnikpad.com/socorro-header-20090612-164550.png

Please just remove the "Mozilla Developer" thing. It's not very useful. The "Mozilla Home" link isn't very useful either.

I'm completely unclear as to what to do in that screenshot other than "choose a product". I don't know what the "Topcrashers" link will show me or what any of the version numbers will show me.

The "choose your product" thing is fine, but it can't be the only entry. If I want to do queries, do I need to choose a product? We should only have one query UI, not multiple depending on product.
Comment 10 Neil Lee [:neilio] 2009-06-12 17:10:43 PDT
Thanks for the feedback!

The original idea with the header is that was to go on top of all of the developer sites - right now there's no linkage between them, and while longtime contributors know those sites exist, many new to the community do not. If it absolutely drives you nuts I suppose we could remove it, but my understanding is the site is supposed to work for both veterans as well as people new to the community.

Sorry if I wasn't more clear - this is a new header to replace the current one. Everything else you see on the site stays - this was just a quick fix to surface up the UUID search and make it easier to jump to top crashers, pages like this: http://talkback-public.mozilla.org/reports/firefox/ etc.

As I mentioned in the comments, the topcrasher link goes to a page similar to this wireframe: http://blog.mozilla.com/webdev/files/2008/12/topcrashers-full.png - it hasn't been implemented yet but was part of the original redesign.
Comment 11 Neil Lee [:neilio] 2009-06-24 12:01:20 PDT
Created attachment 384929 [details]
New version of the header global nav

Here's a new version of the header nav.

- removed "mozilla home" link and "mozilla developer" jump menu
- added server status and admin links to the top nav bar (not sure if admin needs to appear all the time, but it could be toggled on/off based on the user)
- refined the tertiary nav to show product-specific reports and jump menu to go to a specific product version. One of this nav's items could be "All versions" to jump to the topcrashers page for that product, or we could call that out as a link in the nav itself if it should be more prominent.
Comment 12 Neil Lee [:neilio] 2009-07-07 13:02:37 PDT
Created attachment 387251 [details]
Various states of the new global nav

Here's wireframes that show the various state of the global nav, with the condensed "show by version" drop down that appears on the individual crash signature pages.

The versions in that dropdown are condensed to just the most frequently used ones (according to people I asked). This avoids having a ginormous list of versions in the drop down. Selecting "List all Firefox Versions" would jump to a page similar to this: https://bug465659.bugzilla.mozilla.org/attachment.cgi?id=349038
Comment 13 Neil Lee [:neilio] 2009-07-07 13:03:48 PDT
Created attachment 387252 [details]
Screenshot of the new nav in context (on top of a Camino crash signature)
Comment 14 Ryan Snyder [:ryansnyder] [:rsnyder] [:rysny] 2010-02-24 17:12:29 PST

*** This bug has been marked as a duplicate of bug 539742 ***

Note You need to log in before you can comment on or make changes to this bug.