rich messages (HTML) do not render wingdings font (a symbol font) e.g. displays "J" instead of ☺ smiley

RESOLVED DUPLICATE of bug 90643

Status

--
minor
RESOLVED DUPLICATE of bug 90643
11 years ago
11 years ago

People

(Reporter: wallfur+mozbugz, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-AU; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: version 2.0.0.4 (20070604)

of course the source of these symbols in wingdings is usually microsoft outlook clients, however the problem is easily reproduced when composing a new email from scratch in TB and inserting HTML that includes:
<span style="font-family: Wingdings;">J</span>

the failure of thunderbird to render the font occurs both in viewing and composing windows. I don't know why this is a problem as windings is just an opentype font. It occurs for any character not just the commonly used smileys.

Reproducible: Always

Steps to Reproduce:
view a rich (html) message with windings text in it as above as above
Actual Results:  
span shows up in default font (e.g. times new roman)

Expected Results:  
should be rendered in corresponding symbol of wingdings
(Reporter)

Comment 1

11 years ago
Posted image inserted html
(Reporter)

Comment 2

11 years ago
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0
Since we don't have a separate rendering engine, that's the same situation as with any Gecko-based browser - if you use <font face="Wingdings">J</font> then you get the backward-compatible, author-intended, but wrong, symbol from Wingdings, but if you use CSS including font-family: Wingdings, you get the correct behavior, a J from another font since Wingdings doesn't have a glyph for a J, just a symbol in the same place where most fonts have a J. See dozens and dozens of bugs in various Core components, where every argument for "just give me what we both know the author intended" has been raised and failed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 90643
You need to log in before you can comment on or make changes to this bug.