Last Comment Bug 411710 - Land bug 384304 on the 1.8 branch for all non-Firefox/SeaMonkey products
: Land bug 384304 on the 1.8 branch for all non-Firefox/SeaMonkey products
Status: RESOLVED FIXED
: fixed1.8.1.12
Product: Core
Classification: Components
Component: General (show other bugs)
: 1.8 Branch
: x86 Linux
: -- major (vote)
: ---
Assigned To: H. Montoliu
:
:
Mentors:
Depends on: 384304
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-10 10:37 PST by Reed Loden [:reed] (use needinfo?)
Modified: 2008-01-30 16:38 PST (History)
7 users (show)
dveditz: blocking1.8.1.12-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
1.8 branch patch from bug 384304 (2.41 KB, patch)
2008-01-10 10:37 PST, Reed Loden [:reed] (use needinfo?)
reed: review+
dveditz: approval1.8.1.12+
Details | Diff | Splinter Review

Description Reed Loden [:reed] (use needinfo?) 2008-01-10 10:37:32 PST
Created attachment 296363 [details] [diff] [review]
1.8 branch patch from bug 384304

+++ This bug was initially created as a useless clone of Bug #384304 +++

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20061201 Firefox/2.0.0.4 (Ubuntu-feisty)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20070601 Ubuntu/7.10 (gutsy) Firefox/2.0.0.4

If you call firefox through a symlink, e.g. /etc/alternatives/x-www-browser you get the error:

(gutsy_chroot)hjmf@paleo:/$ x-www-browser

run-mozilla.sh: Cannot execute /usr/lib/firefox/x-www-browser-bin.

The link in alternatives is OK:

(gutsy_chroot)hjmf@paleo:/$ ls -l /etc/alternatives/x-www-browser
lrwxrwxrwx 1 root root 16 Jun 11 14:06 /etc/alternatives/x-www-browser -> /usr/bin/firefox

After looking at /usr/bin/firefox script the error seems to be:  in the part that deals with symlinks, seems that somebody missed to pass back the resulting "$progbase" variable to the main process.

Possible patch can be:
--- /usr/bin/firefox	2007-06-13 15:37:26.000000000 +0200
+++ /usr/bin/firefox	2007-06-13 16:23:40.000000000 +0200
@@ -111,6 +111,7 @@
     bn=`basename "$progname"`
     cd `dirname "$progname"`
     progname=`/bin/ls -l "$bn" | sed -e 's/^.* -> //' `
+    progbase=`basename "$progname"`
     if [ ! -x "$progname" ]; then
       break
     fi





Reproducible: Always

Steps to Reproduce:
1. create a symlink to /usr/bin/firefox; e.g. ln -s ./foo /usr/bin/firefox
2. execute the symlink: ./foo
Actual Results:  
the error that raises is:
run-mozilla.sh: Cannot execute /usr/lib/firefox/foo-bin.

Expected Results:  
Should launch the browser as it was meant in the script
Comment 1 Reed Loden [:reed] (use needinfo?) 2008-01-10 10:38:41 PST
This is a blocker for Linux distros. The ones affected by it have already taken the patch themselves, so it's best to get it in our tree to help everybody.
Comment 2 Robert Kaiser 2008-01-10 12:04:10 PST
Just curious: why are you excluding SeaMonkey here?
Comment 3 Reed Loden [:reed] (use needinfo?) 2008-01-10 12:07:05 PST
(In reply to comment #2)
> Just curious: why are you excluding SeaMonkey here?

Because I already landed the patch for SeaMonkey in bug 384304. :)
Comment 4 Robert Kaiser 2008-01-10 12:15:12 PST
ah, sure, thanks. (I obviously approved it myself but got confused as I never actually saw the patch against the xpfe file :)
Comment 5 Daniel Veditz [:dveditz] 2008-01-10 16:15:49 PST
not blocking
Comment 6 Daniel Veditz [:dveditz] 2008-01-10 16:16:03 PST
Comment on attachment 296363 [details] [diff] [review]
1.8 branch patch from bug 384304

approved for 1.8.1.12, a=dveditz for release-drivers
Comment 7 Reed Loden [:reed] (use needinfo?) 2008-01-10 19:20:45 PST
Checking in mail/app/mozilla.in;
/cvsroot/mozilla/mail/app/mozilla.in,v  <--  mozilla.in
new revision: 1.5.4.2; previous revision: 1.5.4.1
done
Checking in calendar/sunbird/app/mozilla.in;
/cvsroot/mozilla/calendar/sunbird/app/mozilla.in,v  <--  mozilla.in
new revision: 1.7.2.4; previous revision: 1.7.2.3
done
Checking in xulrunner/app/mozilla.in;
/cvsroot/mozilla/xulrunner/app/mozilla.in,v  <--  mozilla.in
new revision: 1.2.8.2; previous revision: 1.2.8.1
done
Comment 8 Al Billings [:abillings] 2008-01-30 16:38:09 PST
Reed, can you verify this bug with the RC1 2.0.0.12 build?

Note You need to log in before you can comment on or make changes to this bug.