TT: early and optimistic binding changelist 273 causes dramatic slowdown in AS3Chess benchmark

VERIFIED FIXED

Status

VERIFIED FIXED
11 years ago
9 years ago

People

(Reporter: stejohns, Assigned: edwsmith)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
I was getting nps>200 before, now I get nps ~40. Dropping MAXTRACE from 20000 back to 2000 helps some (nps ~160) but clearly something odd is going on. Needs investigating.
(Assignee)

Comment 1

11 years ago
I'm seeing huge amounts of time in mark/sweep, as well as many trace buffer flushes.  Investigating whether calling LCompressedBuffer.clear() after each trace is generated will let us avoid calling GC::Collect() explicitly.

(Assignee)

Comment 2

11 years ago
Created attachment 297228 [details] [diff] [review]
Bump trace cache to 16M to avoid thrashing

Also
- support SWITCH in trace()
- free LIR buffers explicitly at end-of-trace time
Attachment #297228 - Flags: review?
(Assignee)

Updated

11 years ago
Attachment #297228 - Flags: review?(stejohns)
Attachment #297228 - Flags: review?(rreitmai)
Attachment #297228 - Flags: review?
(Reporter)

Updated

11 years ago
Attachment #297228 - Flags: review?(stejohns) → review+
(Assignee)

Updated

11 years ago
Duplicate of this bug: 412279

Comment 4

11 years ago
Comment on attachment 297228 [details] [diff] [review]
Bump trace cache to 16M to avoid thrashing

we might need to tweak pendingTrace.gen later since it holds onto the buffer.   But that should be fine for now until we implement trees.
Attachment #297228 - Flags: review?(rreitmai) → review+
(Assignee)

Comment 5

11 years ago
pushed as
http://hg.mozilla.org/tamarin-tracing/?rev/0819b9276a59
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 6

9 years ago
Closing out all TT: transfer bugs that are resolved fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.