Closed Bug 412366 Opened 14 years ago Closed 14 years ago

CSS width attribute for <input> does not render properly when <input type="file">

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 52500

People

(Reporter: bugzilla, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b2) Gecko/2007121014 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b2) Gecko/2007121014 Firefox/3.0b2

when I set the width of an <input type="file"> element, firefox does not apply the attribute properly.  In firefox 3-beta2 it crops the "browse" button, and in FF 2.0.0.11, it "overflows" the browse button beyond the specified width.

Reproducible: Always

Steps to Reproduce:
1.Load page.
2.See bad CSS rendering.
Actual Results:  
I saw the rendering issue.

Expected Results:  
render the input element (box and button) at the specified (CSS) width. No cropping, no overflow.

I'm running OSX leopard (10.5)
The cropping of the button is fixed in nightly builds (bug 409587).

As for the width not being applied, input[type="file"] has only very limited support for author styling. That is covered by bug 52500.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: input[type=file]
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.