Closed Bug 412962 Opened 12 years ago Closed 12 years ago

The filters of task pane should contain "Open Tasks" or "Not Completed Tasks"

Categories

(Calendar :: Tasks, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mdelorme, Assigned: giermann)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: 

I would like reopen this bug.
IMHO, the task mode tries to answer the question : "What I have still to do ?",
and what is the priority ?"
the filter doesn't offer "Show/ Not completed tasks" which is according to me
the most important filter.
I will suggest to remove "Not Started Tasks" by "Not completed Tasks"
and put it in first Rank, 
Personally I barely use the due date for a task, so "Today" or "Next Seven
Days" are not for me the most important filters, and also because I've got the
answer in the today pane.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Component: Lightning Only → Tasks
QA Contact: lightning → tasks
Summary: The filters of taks pane should contain "Not Completed Tasks" → The filters of task pane should contain "Not Completed Tasks"
The Today Pane has a 
[ ] Hide Completed Tasks
checkbox/filter. All that really needs to happen is to have that same checkbox/filter in the Task View/Mode.

If the Hide Completed Tasks checkbox is incorporated into that view, then the Show radio button block doesn't need to change, unless an option is added to specify the number of days ahead to look... 
Something like: 
( ) Next [ ] days instead of 
( ) Next seven days
but that's outside the scope of this bug report (I think).
Looking at the current design, I would add an option to the radio-button-list which would be "Open tasks".

Could someone from the UI-Team give his opinion on this?
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
OS: Windows Vista → All
Hardware: PC → All
Target Milestone: --- → 0.9
Assignee: nobody → MarkusAdrario
Status: ASSIGNED → NEW
similar bugs : 
bug 386596
bug 350218
bug 201664
Flags: wanted-calendar0.8?
Not going to happen for 0.8.
Flags: wanted-calendar0.8? → wanted-calendar0.8-
(In reply to comment #1)
> The Today Pane has a 
> [ ] Hide Completed Tasks
> checkbox/filter. All that really needs to happen is to have that same
> checkbox/filter in the Task View/Mode.

I would not suggest this, as it was my first thought, too...

The view "Not Started Tasks" does already hide completed tasks and the view "Completed Tasks" together with "Hide Completed" would always be empty.

I would suggest to add "Open Tasks" or "Not Completed Tasks" and change the checkbox in the today pane to be a drop-down list with exact the same choices.

But you're right: that's something for UI-Team (Christian) - give him time to answer after 0.8 release...
Blocks: 418263
I'd suggest that the "Completed tasks" option should be removed from the menu and implemented thru a button "Hide completed tasks" (or even an additional menu with options "Completed", "Not completed" and "All", but this could be overkill).
The reason is that there's the need to filter both by time and status. I personally seldom filter by time, but always liked to hide completed tasks.
Also, IMHO, the option "Completed tasks" in the checkbox is way less useful than "Not completed tasks".
Best regards
Duplicate of this bug: 431064
(In reply to comment #2)
> Looking at the current design, I would add an option to the radio-button-list
> which would be "Open tasks".
> 
> Could someone from the UI-Team give his opinion on this?
> 

Christian, could you comment on this?
Flags: wanted-calendar0.9?
Flags: wanted-calendar0.9?
Flags: wanted-calendar0.9+
Flags: wanted-calendar0.8-
Attached patch patch v1 (obsolete) — Splinter Review
Simply adding a radio option.

@Christian: How should it be named? (Is now "Not Completed Tasks", although I'd prefer Markus' "Open Tasks")

@Markus: Could you have a look at my patch? Sorry for posting on your bug...
Do you have another solution or idea working?
Assignee: MarkusAdrario → giermann
Status: NEW → ASSIGNED
Attachment #322745 - Flags: ui-review?(christian.jansen)
Attachment #322745 - Flags: review?(Berend.Cornelius)
Attached patch patch v2 ("Open Tasks") (obsolete) — Splinter Review
Patch looks good and uncritical at first sight. But as Christian has not yet commented if he wants this at all I will wait for his ui-review. Currently he is on vacation till June 8th.
Yes, the patch looks good and very similar to what I have in my tree as well. I just didn't attach a patch since I couldn't really test the patch with the task view currently being broken.
Oh, and I would vote for "Open Tasks" as well, since "Not completed tasks" is more complicated to decode IMO.
In my opinion "Open Tasks" doesn't sound correct (but I'm not a native English speaker in case that matters). How about "Active Tasks"? For me this implies "All Tasks" minus "Completed Tasks".
"Uncompleted" or is this a bad translation of a Dutch word?
"Not completed" is too long (too polluting), and "Open" would not translate well.
"Active" sounds good. Maybe "Running"?
If "Not Completed" is too space-consuming, how about "Incomplete" tasks? To me, "Active" has a connotation of being on the top of my priorities, being solved at the moment. I use Lightning/Sunbird for other long-term tasks to which "Incomplete" would be a much better superset. :)

"Incomplete" is good. It means the tasks wait for something to be done, which is precisely the case. But I disagree on "Active": it doesn't sound to me as priority, but something that is ongoing, or waiting for action, etc.
When the task is completed, which is the word used in English Lightning? Dunno if you use "Done" or "Completed". If it's "Completed" (as in Portuguese), then "Incomplete" perfectly suits the task (and would translate well too). If it's "Done", then both "Incomplete" and "Active" are OK.
Best regards
+1 for "Incomplete Tasks".

My second choice would be "Open Tasks", but it isn't obvious that it refers to completed/incomplete tasks.  For example, "Open Tasks" could also refer to non-cancelled tasks or to tasks that are between their Start Date and Due Date, so it's meaning isn't very clear IMO.

@Bas, 'Uncompleted' works and means the same thing, but I think that 'Incomplete' sounds a little better.
IMO "Incomplete" or "Uncomplete" is better than "Open Tasks" that seems to exclude tasks not started or not in process.
This was a necessary improvement, I couldn't wait and I modified manually the files to try it. Well done!!

I have to say that now could be a vertical space problem. Seven option take more space than the calendars list.
I tried to reduce space between radio buttons (to make them as narrow as calendars in calendars list) but I found some CSS selectors that haven't padding or dimension properties, could someone tell me where they are?

Maybe a drop-down list could be more appropriate and could free much space (maybe to add another drop-down list for filtering by date or others criteria?),
but this is material for file another bug.

Thanks for fixed this.
Yes, a drop-down list would be a good option. But, if it's not possible for any reason, I'd elliminate the "Completed tasks" option, which is completely useless for me. Unless other people think otherwise, sure.
Thanks a lot!
In my opinion a show completed Tasks option is absolutely necessary.
How would you delete completed tasks if you can't see them?
Also I tend to just set recurring tasks as incomplete again if they reoccur.
Summary: The filters of task pane should contain "Not Completed Tasks" → The filters of task pane should contain "Open Tasks" or "Not Completed Tasks"
Agreed! Change my vote to drop-down menu with both "Complete" and "Incomplete". But, until we have the menu, the Decathlon change is more than welcome.
Better still if we took this out of the options and had an additional menu or whatever with the options Complete/Incomplete/All. So it would be independent of the time filtering. Would be perfect in my opinion.
How can I give a shot at this patch? I use a localized build. Can I edit my calendar-task-view.js file to have this option added? How would it be?
After this patch is checked, I'll be able to localize it thru l10n, but so far I'll have to do it manually.
Many thanks.
I agree that  "Completed" and "Incomplete" makes sense.  Regarding the vertical space. A Drop down mixed with the radio buttons would destroy the layout. We have two options to save vertical space.

The first (which I do prefer) We add "Incomplete" to the list and remove the drop down below the mini moth. In addition we decrease the amount of space used between " >Show" and the mini month.

The second: we move all filter items into a drop down.
Vote for the first option! ;) There's indeed too much gap between "Show" and Mini Month and I don't see a reason for the drop down below Mini Month (if someone uses that for something, pls advice). IMHO, that would make the options complete (pun intended).
Best regards
Sven, can you implement the changes proposed in Comment #25, Option 1?
Sven, are you going to apply the changes of Christian? It would be good if we could get this patch in!
Sven, do you think you can deliver a new patch within this wee? As we are most likely going to have our string freeze at the beginning of the coming week, this would be great.
Unbitrotted the patch v2 and replaced String as supposed in commment #25

Here is a citation from mvl worth being read in
Bug 377753 comment 12 – Look and Feel of minimonths should be adapted
>The dropdown is for easy typing a date. That's usually faster, if you know the
>date. The dropdown itself is not needed here, indeed. A single textbox would
>do. Less double options -> less confusion -> better.
>It might not need to be in the position it currently is. A popup of some sort
>might work.

Maybe we could handle this in another bug.
r=berend
Attachment #322745 - Attachment is obsolete: true
Attachment #322746 - Attachment is obsolete: true
Attachment #322745 - Flags: ui-review?(christian.jansen)
Attachment #322745 - Flags: review?(Berend.Cornelius)
Attachment #329423 - Flags: ui-review?(christian.jansen)
Attachment #329423 - Flags: review?(daniel.boelzle)
(In reply to comment #30)
> Created an attachment (id=329423) [details]
> unbitrotted patch v. #3  with new string
> 
> Unbitrotted the patch v2 and replaced String as supposed in commment #25
> 
> Here is a citation from mvl worth being read in
> Bug 377753 comment 12 – Look and Feel of minimonths should be adapted
> >The dropdown is for easy typing a date. That's usually faster, if you know the
> >date. The dropdown itself is not needed here, indeed. A single textbox would
> >do. Less double options -> less confusion -> better.
> >It might not need to be in the position it currently is. A popup of some sort
> >might work.
> 

> Maybe we could handle this in another bug.

+1
> r=berend
> 

ui=christian
Attachment #329423 - Flags: ui-review?(christian.jansen) → ui-review+
Comment on attachment 329423 [details] [diff] [review]
unbitrotted patch v. #3  with new string

r=dbo
Attachment #329423 - Flags: review?(daniel.boelzle) → review+
patch checked in on trunk and MOZILLA_1_8_BRANCH
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
@Berend:
Thanks for taking and solving this one!

@Christian:
I appolgize for ignoring your questions - seems I was too busy last weeks to even realize notifications on this bug :confused:
Checked in build 2008071619 -> VERIFIED
Status: RESOLVED → VERIFIED
(In reply to comment #25)
> ...Regarding the vertical space... We have two options to save vertical space.
> 
> The first... We... remove the drop down below the mini moth. In addition we decrease the amount of space used between " >Show" and the mini month.
> 
> The second: we move all filter items into a drop down.

Lightning has just updated itself and the new option is there. But none of the two ideas above was implemented (as far as I can see), and at least one is needeed. My task pane looks a bit screwed now, as the calendars aren't visible anymore (unless I collapse the task pane). I still think the above ideas would be a painless path to make everything visible simultaneously, what is important IMHO.
Best regards
You need to log in before you can comment on or make changes to this bug.