Closed Bug 412971 Opened 12 years ago Closed 9 years ago

Bad formating of invitations - Weblinks in invitation unusable

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: balengyel, Unassigned)

References

Details

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Lightning 0.7 main release    thunderbird version 2.0.0.4 (20070604)

When I receive an invitation from Microsoft Exchange V6.5 
Lightning formats it. The headers are wonderful, but the text/Description of the invitation is garbled. Newlines are missing weblinks are not marked as such: altogether unreadable.

Reproducible: Always

Steps to Reproduce:
1. receive an invitation from Exchange and open it


Actual Results:  
I see nice headings and then garbled text

Expected Results:  
Text should be unformated or properly formated, weblinks should be presented as such.
Flags: wanted-calendar0.8+
Version: unspecified → Lightning 0.7
Only release drivers can grant wanted-calendar0.8+. Setting to wanted-calendar0.8?.
Flags: wanted-calendar0.8+ → wanted-calendar0.8?
There's a similar problem when I receive an invitation from Outlook 2007 (so it's not just a problem with MS Exchange).  I also don't think that this bug is specific to Linux because I use WinXP.
Severity: major → normal
OS: Linux → All
Hardware: PC → All
Please get this bug confirmed before requesting wanted-status.
Flags: wanted-calendar0.8? → wanted-calendar0.8-
Confirmed based on the attached email. If I remove the calendar part from the email, the link is displayed correctly. I'm not sure if we want to display the html-version of an multipart/alternative message below the invitation box.

Of course, also http:// addresses in the DESCRIPTION field could be recognized as such and displayed as a link.
Status: UNCONFIRMED → NEW
Ever confirmed: true
The formating of the text using basic whitespace chars like new-line, spaces and tabs should also be preserved. They work fine in a normal email, why are these whitespaces collapsed when formatting as an invitation?
+1

I would like to see plain text formatting preserved.
Component: Lightning Only → E-mail based Scheduling (iTIP/iMIP)
QA Contact: lightning → email-scheduling
The 0.8 release now preserves the event formating, at least for me.

html links are presented correctly, however it is still not possible to click-on them to open them.
(In reply to comment #10)
> The 0.8 release now preserves the event formating, at least for me.
> 
> html links are presented correctly, however it is still not possible to
> click-on them to open them.

Yes, the formatting is now OK. But links cannot be clicked on.

This patch improves the situation. Links are linkified in the COMMENT and DESCRIPTION fields. Unfortunately, the text converter stuff from thunderbird is not scriptable, so we need to roll our own or consolidate between the two apps.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #329050 - Flags: review?(daniel.boelzle)
Comment on attachment 329050 [details] [diff] [review]
[checked in] Improve the situation - v1

r=dbo for the improvement
Attachment #329050 - Flags: review?(daniel.boelzle) → review+
Attachment #329050 - Attachment description: Improve the situation - v1 → [checked in] Improve the situation - v1
Improvement checked in, if you are inclined to fix this using a nsIStreamConverter and it becomes possible to use it (synchronously), or there is another way to do the mime conversion asynchronously, go ahead.
Assignee: philipp → nobody
Status: ASSIGNED → NEW
Version: Lightning 0.7 → unspecified
Setting qawanted: We need to verify the improvement, although this bug is not completely fixed.
Keywords: qawanted
links are hightlighted and clickable. 

Line breaks are preserved.

Close?
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Can be closed, Balazs
Duplicate of this bug: 597512
Flags: wanted-calendar0.8-
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.