Closed Bug 413011 Opened 13 years ago Closed 12 years ago

Freetags should be locale specific

Categories

(support.mozilla.org :: Knowledge Base Software, task)

task
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: djst, Assigned: nkoth)

Details

(Whiteboard: tiki_fixed)

Tags should be locale specific, meaning there should be separate sets of tags per locale. Otherwise, the list of related articles will include any and all locales.
Dup of bug 411584 ?
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 411584
bug 411584 will be solved differently, by just showing only pages that are the same as the page lang. This is somewhat different from more generically having freetags being locale specific (which has some way to translate tags, i.e. information will be stored about which tags are translations of other tags in other languages) 
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
there is a fix that will be committed once db schema updates are in. Once this is in, we need to go through the current list of tags (a tool exists) and assign languages to them. If you don't do this, the tags remain "universal" and apply to all languages. (There are some tags that you may want to keep universal).

There are some obvious limitations (improvements will not be in till later and I suggest new bugs be filed after testing):

1) New tags created on pages with languages are automatically assigned to the language of the page (which is usually desired). However, this means that to create a new universal tag, you need to set it on a page that has "Unknown" (i.e. not set) language.

2) Once a language is assigned to a tag, there is no way to change it. 

3) There is no way to "edit" a translation of a tag (or edit tags in general). Of course, the workaround is simply to create a new tag in that language, but this is less than ideal.



I'm not too worried about how hard it is to have "universal" tags. Very few tags (maybe none) will be the same in every language.
I still think we'll need to assign a language to each freetag, because of bug 398770 [Need a listing of all freetags in editor].
The system is in place. English tags are already marked as such.

Approvers and locale leaders now need to go to  http://support.mozilla.com/tiki-freetag_translate.php to identify other language tags as a certain language (otherwise they remain universal and will appear as suggested tags under edit boxes regardless of the language).

A shorter version of this page (listing only the tags of a particular page) can be reached through the "translate this page" link on individual pages.

By the way, limitation #2 in comment #4 above has been resolved.
is there anything else I have to do for this bug?
I don't think there is. We just need to periodically check for freetags that are not assigned to a language.
Status: REOPENED → RESOLVED
Closed: 13 years ago12 years ago
Resolution: --- → FIXED
v
Status: RESOLVED → VERIFIED
Whiteboard: tiki_fixed
You need to log in before you can comment on or make changes to this bug.