Closed Bug 413101 Opened 17 years ago Closed 16 years ago

calendar view missing background

Categories

(Calendar :: Calendar Frontend, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: bvdbos, Assigned: sipaq)

Details

Attachments

(3 files, 1 obsolete file)

With the latest hourly build on a fresh profile the calendar-view and task-view is missing it's background. No error in console (see screenshots of build 2008011823 on TB 2.0.0.9). No error in console.
Flags: blocking-calendar0.8?
Attached image sunbird screenshot
I can confirm similar theme errors, like missing borders around the sidebar elements in Sunbird 0.8pre (2008011902). This makes it look "incomplete" in my opinion compared to Sunbird 0.7.
The relevant css rule has been introduced with bug 411497 in order to move on towards the specification, see [1] for details. The changes to make the minimoth control look like on the mockup are still outstanding. Probably Christian can comment on this as well. I personally find the look less ancient than the default theme.

[1] http://wiki.mozilla.org/Calendar:Improving_the_Calendar_Views#Tasks
So should we set it to WONTFIX to show "this is working as designed"???
Thanks for doing so much to improve the appearance of Lightning, but I think it's wrong to hardcode background colors.  I realize that this is a common practice in the calendar code, but using this bug as an example, just because the wiki happens to use a white background doesn't mean that everybody uses a white background.

And while I understand that maybe it's necessary in the views, it would be nice if this could be avoided with more general things such as the sidebar.

For the benefit of non-technical people who read this bug and don't use a white background on their computers, I fixed this with the following addition to my userchrome.css:

#ltnSidebar {
     background-color: transparent !important;
}

Because I use a gray background on my computer, my workaround has the side-effect that I can't see the thin gray line under the word "Calendar", but that's a minor tradeoff for me.  It would be nice if the color of the thin line could be abs(<backgroundColor> - 100) or something.
I agree. One goal of Lightning is to tightly integrate into Thunderbird. Therefore the default Lightning theme should use native skinning as much as possible to match the Thunderbird appearance.
(In reply to comment #4)
> The relevant css rule has been introduced with bug 411497 in order to move on
> towards the specification, see [1] for details. The changes to make the
> minimoth control look like on the mockup are still outstanding. Probably
> Christian can comment on this as well. I personally find the look less ancient
> than the default theme.
> 
> [1] http://wiki.mozilla.org/Calendar:Improving_the_Calendar_Views#Tasks
> 

For Lightning the new design is a huge step forward, but it causes some severe design issues for Sunbird. I didn't recognized the side effects earlier, because I've reviewed the patch on Lightning only. Sorry for that.

Mickey: Do you see any possibility that we offer two styles? One for Sunbird, which sticks to the design of .7 and another for Lightning which follows the approach specified in http://wiki.mozilla.org/Calendar:Improving_the_Calendar_Views#Tasks ?
(In reply to comment #8)
> Mickey: Do you see any possibility that we offer two styles? One for Sunbird,
> which sticks to the design of .7 and another for Lightning which follows the
> approach specified in
> http://wiki.mozilla.org/Calendar:Improving_the_Calendar_Views#Tasks ?
I strictly advise against diverging the theme of Sunbird and Lightning. Although it would be technically possible it would be a maintenance nightmare. Furthermore, we already have Lightning only rules for those elements that are specific to Lightning. The offending rule we're discussing here is Lightning only, as it affects the calendar/task pane (which isn't available in Sunbird). The question is whether or not we should introduce rules that fork the carefully thought-out platform-specific rules of the mozilla toolkit. Admittedly, Thunderbird looks a bit old-fashioned, but this is nothing Lightning should change. I would strongly, strongly advise not to do such things. I just did it because the design dictates it. But it would be much better to change themes by using an overarching theme for the whole application.
Attached patch Remove hardcoded color (obsolete) — Splinter Review
Pete and Stefan are right. We should not hardcode colors here to override TB's default colors.
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
Attachment #298677 - Flags: review?(michael.buettner)
Comment on attachment 298677 [details] [diff] [review]
Remove hardcoded color

> #ltnSidebar {
>-  background: white;
>+  background: transparent;
> }
Just remove the whole rule, no need to unnecessary rules. r=mickey. But asking Christian for ui-review.
Attachment #298677 - Flags: ui-review?(christian.jansen)
Attachment #298677 - Flags: review?(michael.buettner)
Attachment #298677 - Flags: review+
Flags: blocking-calendar0.8? → blocking-calendar0.8-
(In reply to comment #8)
> For Lightning the new design is a huge step forward, but it causes some severe
> design issues for Sunbird. I didn't recognized the side effects earlier,
> because I've reviewed the patch on Lightning only. Sorry for that.
> 
> Mickey: Do you see any possibility that we offer two styles? One for Sunbird,
> which sticks to the design of .7 and another for Lightning

I would strongly advise against that. IMO the right to do here is to better align the Lightning and Sunbird UI. I think the first step here would be a port of the task mode to Sunbird (bug 405508). Then we can display the calendar list and the minimonth in the same way on Sunbird as it is already done on Lightning.
Comment on attachment 298677 [details] [diff] [review]
Remove hardcoded color

I agree that a hard coded "-  background: white;" is not good. Thus I suggest to use the same rule like specified for background of Thunderbirds Mail Folder Tree.
Attachment #298677 - Flags: ui-review?(christian.jansen) → ui-review-
Flags: blocking-calendar0.8- → wanted-calendar0.9?
Flags: wanted-calendar0.9? → wanted-calendar0.9+
(In reply to comment #13)
> I agree that a hard coded "-  background: white;" is not good. Thus I suggest
> to use the same rule like specified for background of Thunderbirds Mail Folder
> Tree.

Christian, Thunderbird uses the -moz-Dialog color as can be seen here:
http://mxr.mozilla.org/mozilla1.8/source/mail/themes/qute/mail/mailWindow1.css#69

Would you r+ a patch, that uses "-moz-Dialog" instead of "transparent" as background-color?
OS: Windows XP → All
Hardware: PC → All
I think this would also turn the background in dialog color and not in window color (on windows -> Desktop -> Properties -> Advance ->Window)

Christian, can you please think carefully about what you want here.

I think everybody agrees that the current way is far from optimal, so I suggested to use "background-color: transparent" to pick up the background color from the respective app (TB or SB). 

You r-'ed that patch claiming that you wanted "the same rule like specified for background of Thunderbirds Mail Folder Tree" which is "-moz-dialog". But now you turn around again and no longer seem to like what yopu proposed nearly three months ago.

So, please, please give me a clear statement that I can work with. I'm very near to assigning it back to nobody@mozilla.org...

I don't know if that's the intended outcome of this bug?
I'm having the same problem, I use a near-black theme in Gnome and the left calendar pane is clear white while checkboxes and selectboxes remain near-black.

Could this be fixed, it looks quite ackward right now. (It does not look like tight integration right now)

Lightning 0.8 (Build 2008033118)
Thunderbird 2.0.0.12 (Build 20080227)
OK, Christian was right, -moz-dialog was the wrong color, but -moz-field is the way to go. I'll whip up a new patch soon. 

Stefan, regarding your comment 2 as shown in attachment 297949 [details], this is definitely a separate issue and should be handled as such. Please file a separate bug for the missing borders in the Sunbird calendar list.
Better patch using system colors as discussed on the Hamburg F2F meeting. 

Christian, please try this out on Mac just to make sure that it does what's intended there as well.
Attachment #298677 - Attachment is obsolete: true
Attachment #316715 - Flags: ui-review?(christian.jansen)
Attachment #316715 - Flags: review?(philipp)
Comment on attachment 316715 [details] [diff] [review]
Patch v2 (using system colors)

r=philipp
Attachment #316715 - Flags: review?(philipp) → review+
Christian, this bug has been waiting for your review and feedback for over two weeks now. Any estimate when you might get to this? I really would like to get this out of my tree.
Comment on attachment 316715 [details] [diff] [review]
Patch v2 (using system colors)

Looks good. r=christian
Attachment #316715 - Flags: ui-review?(christian.jansen) → ui-review+
Patch checked in on HEAD and MOZILLA_1_8_BRANCH.
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.9
Checked in nightly build 2008072919 -> VERIFIED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: