Task Mode: Full Task Window for Sunbird

RESOLVED WONTFIX

Status

Calendar
Sunbird Only
--
enhancement
RESOLVED WONTFIX
10 years ago
5 years ago

People

(Reporter: aryx, Unassigned)

Tracking

unspecified
Bug Flags:
wanted-calendar1.0 +

Details

Attachments

(2 attachments)

Please add a full task window to Sunbird like bug 253396 did for Lightning.

Comment 1

10 years ago
I would like to see this addressed in the 0.8 timeframe, mainly to keep the two products in sync as much as possible.
Flags: wanted-calendar0.8?

Comment 2

10 years ago
Feature parity between Lightning and Sunbird (as far as possible) is definitely needed for 0.8.

Mickey, I know you're already overburdened, but how much work would it be to hook up our nice and shiny task mode in Sunbird as well?
Flags: wanted-calendar0.8? → blocking-calendar0.8+

Comment 3

10 years ago
(In reply to comment #2)
> Feature parity between Lightning and Sunbird (as far as possible) is definitely
> needed for 0.8.
I don't agree with this; it's wanted though.
Flags: blocking-calendar0.8+ → wanted-calendar0.8+
(In reply to comment #2)
> Mickey, I know you're already overburdened, but how much work would it be to
> hook up our nice and shiny task mode in Sunbird as well?
First of all, we need to distinguish between the two possible ways how the task window could be integrated into Sunbird. The first option is to wrap the task list into a view. This would mean we would have (besides the usual toolbar buttons week/multiweek/month) a new toolbar button called tasks. The second option would be to carry the whole mode concept from Lightning over to Sunbird.

IMHO, the first option is a half-baked version of what is desired. It leaves questions like how we could integrate the task filter, etc. The second option means a hell of a lot of changes. All this mode stuff is currently Lightning only as I was never aware that this should someday be a part of Sunbird. I'm even not sure whether or not there's a third possible option.

Apart from these quick thoughts, there's definitely not enough time for this feature to take the 0.8 train. As I stated above, there are some conceptional bits and pieces that need to be thought about before moving forward. It's not that I'm saying that I wouldn't want to do it, but I'm not seeing the slightest chance of getting this into 0.8.

Comment 5

10 years ago
I think we could do a between both, ie we implement the "task list" in the same way as the unifinder, we have the filtering option already in there, we add a button "find task" like the actual "find event" that would show the task list.

with this option we wouldn't have the bottom part of the Lightning task mode (ie the description) but since we doesn't have it for event either, it shouldn't be a problem yet.

I think that way it's probably not to much work to implement it into sunbird (well there is still work to do). Michael to tell about the time frame.

just a note about the task mode being part of sunbird, it was actually part of bug 253396 to be in both calendar app and as I just saw it's even part of your Bug 402015.  anyway it's now time to see how to do it not why it isn't done, it's already good to have it in lightning.

Comment 6

10 years ago
Not going to happen for 0.8.
Flags: wanted-calendar0.8+ → wanted-calendar0.8-

Comment 7

10 years ago
Apart from all the following comments I agree, that this would not make the 0.8 train...
But:

(In reply to comment #4)
> First of all, we need to distinguish between the two possible ways how the task
> window could be integrated into Sunbird. The first option is to wrap the task
> list into a view. This would mean we would have (besides the usual toolbar
> buttons week/multiweek/month) a new toolbar button called tasks. The second
> option would be to carry the whole mode concept from Lightning over to Sunbird.

Maybe Christian does comment on this...?

(In reply to comment #5)
> I think we could do a between both, ie we implement the "task list" in the same
> way as the unifinder, we have the filtering option already in there, we add a
> button "find task" like the actual "find event" that would show the task list.

IMHO this is no good solution. It's more half-baked (or even quater-baked ;-) ) than Mickey's first suggestion, which would be my favorite.
It even throws the idea of doing this in Lightning as well, but I think it has been discussed enough for Ligthning...

And the integration as a separate view only, throws many other problems:
- Should the (event) unifinder be hidden in this view?
- Should the Today-Pane get it's own state in this view (bug 389150 or it's spin-off for Sunbird)?

So it probably would be best (but also most laborious) to implement mode-switching into Sunbird. But this throws many UI-questions, too. Would this finally degrade Sunbird to a "Thunderbird/Lightning without Mail-mode"?
Flags: wanted-calendar0.8- → wanted-calendar0.8+
Sven, please refrain from changing the wanted flag after a release driver made a decision.
Flags: wanted-calendar0.8+ → wanted-calendar0.8-

Comment 9

10 years ago
(In reply to comment #8)
> Sven, please refrain from changing the wanted flag after a release driver made
> a decision.

Sorry, I did not change this...
It was a 'Mid-Air-Collision' and I did not see, that the flag is changed back by my comment.

Comment 10

10 years ago
> IMHO this is no good solution. It's more half-baked (or even quater-baked ;-) )
> than Mickey's first suggestion, which would be my favorite.
> It even throws the idea of doing this in Lightning as well, but I think it has
> been discussed enough for Ligthning...

sorry I doesn't understand what isn't good in the suggestion, since we would have everything that is in Ligthning except the description bar that is at the bottom(which could probably be directly at the bottom of the task list), and I think it's even better for the sorting part (I actually don't like the way it's done in Ligthning but this is not the subject). I think I'll do a screen shot of my idea to explain it in a better way.

> And the integration as a separate view only, throws many other problems:
> - Should the (event) unifinder be hidden in this view?
> - Should the Today-Pane get it's own state in this view (bug 389150 or it's
> spin-off for Sunbird)?
>
> So it probably would be best (but also most laborious) to implement
> mode-switching into Sunbird. But this throws many UI-questions, too. Would this
> finally degrade Sunbird to a "Thunderbird/Lightning without Mail-mode"?
> 

I would like to keep the calendar in view when working with task so the mode-switching is probably not the good solution for sunbird. I like my idea (as long as I don't understand the problem that you saw...maybe I wont after) or the view idea that is quiet close anyway.

Comment 11

10 years ago
Created attachment 302532 [details]
task mode idea1

this is I think the easiest way to add task mode into sunbird we just have to see what to do with the left-bottom task list, compare to the Lightning task mode we just miss the details part. we could also add the "click here to add new task" bar somewhere around, this proposal need some UI work to be usable but thats the main idea.

Comment 12

10 years ago
Created attachment 302534 [details]
task mode idea2

that is another idea that I had while designing the first one, it's resolve the old task list space problem and the "click here to had new task" bar as well, we are still keeping the calendar pane and we doesn't have to implement switch mode into Sunbird that is probably the worst solution in term of work. we even have some possibility to add a detail pane for event as well (but that is something else for now).

both Idea are using the same design than the actual unifinder so that is probably not to hard to make the addition. another part would be the details pane but we could still adapt the one in Lighting in size so it's fit in Sunbird, that is almost everything I think.

Comment 13

10 years ago
djo0012,

I think I understand your idea better now. I thought before, that you wanted to display the UnifinderToDo additionally to the Unifinder (events).
So this is another point of view - you have to switch between tasks and events list.
Bringing your proposal 2 (attachment #302534 [details]) together with bug 392083, we even have the same functionality as the task mode in Lightning...

But I still think we have to keep both products in one line, so it should be discussed to strip down Lightnings task mode to 'just another list above the calendar'...

CC'ing Christian to comment on this.
(or you should set the UI-review flag for him)

Updated

10 years ago
Attachment #302534 - Flags: ui-review?

Comment 14

10 years ago
Sorry for my late response, but I'm currently swamped with work. I'll comment on the proposal at the end of this, or the beginning of next week. Thanks for understanding.
(In reply to comment #14)
> Sorry for my late response, but I'm currently swamped with work. I'll comment
> on the proposal at the end of this, or the beginning of next week. Thanks for
> understanding.

Christian, your last comment here was in mid-February. Any update?

Flags: wanted-calendar0.8- → wanted-calendar0.9+
Version: Mozilla 1.8 Branch → unspecified

Comment 16

10 years ago
No, not really. I think we should make this a topic on the next face to face meeting.

Comment 17

10 years ago
since f2f meeting is over what is the outcome of it about sunbird task-mode?

Comment 18

10 years ago
http://wiki.mozilla.org/Calendar:Hamburg_2008_-_F2F_Meeting#Day_1_.28Saturday.29_2

Internally it should be a mode like in Lightning, but for the user it should be displayed only as a different view.

I think this could be achieved by simply assign ' mode="calendar,task" ' to all toolbar buttons with an additional sync to ensure that only one calendar view OR the task view is checked.
Another possibility would be to leave the whole mode dependent toolbar buttons in Lightning only, but IMHO it would make sense to switch menus etc. the way Lightning does...

Comment 19

10 years ago
> I think this could be achieved by simply assign ' mode="calendar,task" ' to all
> toolbar buttons with an additional sync to ensure that only one calendar view
> OR the task view is checked.
> Another possibility would be to leave the whole mode dependent toolbar buttons
> in Lightning only, but IMHO it would make sense to switch menus etc. the way
> Lightning does...
> 

I agree that the mode switcher should go into sunbird as well. the only thing I wonder is the fact that the calendar isn't shown in the task mode witch it should be I reckon.  see the proposal screen shot wich was my idea of what should be the task mode view and it's bring some few thing good for the event mode as well(mainly the detail pane on left)
Berend, could you please post your thoughts on this issue as we discussed and agreed it in Hamburg? Thanks!

Comment 21

10 years ago
My idea to integrate the taskmode to Sunbird involves two concepts: 
1) We make use modeboxes that I implemented in calendar/base/content/widgets. These boxes are extensions to ordinary xul-boxes and carry a "mode" attribute which they automatically evaluate when the application mode changes and upon which the box decides on its own whether it's meant to be displayed or not. I guess we need similar bindings for other widgets e.g. for a toolbar, too. All panes and other widgets that are supposed to be displayed in one or several distinctive modes only should become "modeboxes".

2)To consolidate the menu and the left sidebar (messenger-sidebar) and the todaypane I think we should try to keep the changes thunderbird-lightning overlays (messenger-overlay-toolbar.xul and messenger-overlay-sidebar.xul) and the related source (e.g the messenger-overlay-sidebar.js) as little as possible and move as much of it as possible to base/content. All this code currently overlays into thunderbird-specific DOM-elements like "messengerBox", "menu_FilePopup", "menu_NewPopup" etc., which we consequently would have to provide also for Sunbird in the files calendar.xul and menubar in the same way.

Comment 22

10 years ago
(In reply to comment #21)

I think that it's a good way of doing mode switching, I dont have anything to add about this part.

but about the task mode it's self (for both Sunbird and Thunderbird) I would still like to know what you think about the UI proposed in comment #12. It's might go in another enhancement bug after then thought.

Comment 23

10 years ago
I am fine with the UI proposals and I guess that there will be more proposals after the consolidation has been accomplished. Yet I think Sven's comment #18 shows how we should handle them. And I also think that these should be dealt with in follow-up bugs.

Updated

10 years ago
Duplicate of this bug: 431813

Comment 25

10 years ago
(In reply to comment #22)
> but about the task mode it's self (for both Sunbird and Thunderbird) I would
> still like to know what you think about the UI proposed in comment #12.

I fear many users would dislike this UI, because most people have more than 2 or 3 tasks in their list...
The long list shows many more tasks and gives a better overview - maybe there should be a mixed mode (your screenshot) as an enhancement to the current task-only-mode, but that should definitely go into a spin-off.
( Maybe we could switch between EVENT and TASK Unifinder in Calendar mode )

Comment 26

10 years ago
(In reply to comment #25)
> The long list shows many more tasks and gives a better overview - maybe there
> should be a mixed mode (your screenshot) as an enhancement to the current
> task-only-mode, but that should definitely go into a spin-off.
> ( Maybe we could switch between EVENT and TASK Unifinder in Calendar mode )
> 

the suggestion was exactly about switching between both unifinder and with your comment #13 about bug 392083 which maximize unifinder (anyone of them...) but we have to figure out this with the mode switching.
Comment on attachment 302534 [details]
task mode idea2

Removing review flag. Backend has to be changed first, and no requestee was entered.
Attachment #302534 - Flags: ui-review?
Duplicate of this bug: 315700
Duplicate of this bug: 375634
Duplicate of this bug: 379010
Duplicate of this bug: 281217

Updated

10 years ago
Duplicate of this bug: 207384

Updated

9 years ago
Flags: wanted-calendar0.9+ → wanted-calendar1.0+

Updated

9 years ago
Keywords: helpwanted
Sunbird code was removed from tree, bug is no longer required.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: helpwanted
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.