drop -moz-opacity alias

RESOLVED FIXED in mozilla1.9.1b1

Status

()

Core
CSS Parsing and Computation
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: Daniel.S, Assigned: Daniel.S)

Tracking

({dev-doc-complete})

Trunk
mozilla1.9.1b1
dev-doc-complete
Points:
---
Bug Flags:
blocking1.9.1 -
wanted1.9.1 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

10 years ago
The CSS 3 opacity property has been implemented since Gecko 1.7. However, the -moz-opacity alias was never removed. This seems odd, since other experimental properties have been removed after their standard equivalent was implemented.

According to MDC, use of -moz-opacity is deprecated since the implementation of the standard property. opacity is perfectly understood by Presto and WebKit (tested Safari 3 for Win).

Besides, best practice has always been writing proprietary and standard properties:

E {
 filter: alpha(50);
 -moz-opacity: 0.5;
 opacity: 0.5;
}

So, -moz-opacity should be removed, just like -moz-inline-block was when inline-block was finally implemented.

According to LXR some files are still using -moz-opacity, but I think this shouldn't be the problem here.

I have not heard of any reasons that speak against this. However, if I missed the reason please tell me.
The reason I left it (in bug 93156) was that a lot of sites were using it.  That said, I agree I probably should have removed it (as I have done for later property renames).  That said, -moz-opacity is probably the most used -moz-* property on the Web by an order of magnitude.  I'm not sure whether I can justify doing it right before a release (increased risk of catching problems resulting) given the rather low benefits, though.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

10 years ago
I thought it was a bit too late for doing it now. 

Hm, just disabling it for Beta 3 is no option? Well, I better do not spam here. But good to know it's on your radar.
http://mxr.mozilla.org/seamonkey/search?string=moz-opacity :|

Comment 4

10 years ago
The benefits of this would be interoperability (for pages using -moz-opacity but not opacity) and not further encouraging code bloat (for pages using both). The reasoning in bug 93156 was good for backwards-compatibility, but that's also four and a half years ago.
Depends on: 413194
(Assignee)

Comment 5

9 years ago
(In reply to comment #4)
> The reasoning in bug 93156 was good for backwards-compatibility, but that's
> also four and a half years ago.

Yes. Most users of -moz-opacity also use the standard property as well as Microsoft's filter (which is disabled in IE8's no-quirks-mode to implement real opacity instead).
Presto and WebKit both support opacity as well now.

There are a lot of things going on this late in the cycle and some of them can break websites way more than this one. Besides -moz-pre-wrap was quickly removed in Bug #418543. This could/should be just as quick.

Sorry, I guess this can be interpreted as bugspam, didn't want to waste anyone's time.
(In reply to comment #5)
> There are a lot of things going on this late in the cycle and some of them can
> break websites way more than this one. Besides -moz-pre-wrap was quickly
> removed in Bug #418543. This could/should be just as quick.

It wasn't actually.
(Assignee)

Comment 7

9 years ago
(In reply to comment #6)
> It wasn't actually.

Both could be done now, can't they?
Flags: wanted1.9.1?
Flags: wanted1.9.1?
Flags: wanted1.9.1-
Flags: blocking1.9.1-

Comment 8

9 years ago
Would probably be a good time to do this now before a beta because site developers should be checking out their sites with the beta...at least that is what I think.
(Assignee)

Comment 9

9 years ago
Created attachment 339633 [details] [diff] [review]
trying to figure it out

I tried to figure out how this can be done. I probably failed because this is my first patch, but the attempt is more worth than another complaint.
Attachment #339633 - Flags: review?(dbaron)
(Assignee)

Comment 10

9 years ago
Created attachment 339644 [details] [diff] [review]
Second Try

And this time it should actually apply. Sorry.
Attachment #339633 - Attachment is obsolete: true
Attachment #339644 - Flags: review?(dbaron)
Attachment #339633 - Flags: review?(dbaron)
Comment on attachment 339644 [details] [diff] [review]
Second Try

r+sr=dbaron, though this probably shouldn't land after the first beta
Attachment #339644 - Flags: superreview+
Attachment #339644 - Flags: review?(dbaron)
Attachment #339644 - Flags: review+
http://hg.mozilla.org/mozilla-central/rev/03796867bcd2
Assignee: nobody → crazy-daniel
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.1b1

Updated

9 years ago
Keywords: dev-doc-needed

Comment 13

9 years ago
How about removing also the -moz-outline aliases?

Comment 14

9 years ago
http://developer.mozilla.org/en/CSS/-moz-outline:
"Starting with Gecko 1.8 (Firefox 1.5), the standard CSS 2.1 outline  property is supported as well. Use of outline  is preferred to -moz-outline. "
(Assignee)

Comment 15

9 years ago
(In reply to comment #13)
> How about removing also the -moz-outline aliases?

Filed Bug 458588 to achieve this.
The documentation has been updated.
Keywords: dev-doc-needed → dev-doc-complete
You need to log in before you can comment on or make changes to this bug.