Changing calendar for tasks via context menu doesn't work

VERIFIED FIXED in 0.8

Status

defect
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: omarb.public, Assigned: berend.cornelius09)

Tracking

unspecified
Dependency tree / graph
Bug Flags:
blocking-calendar0.8 +

Details

Attachments

(1 attachment, 2 obsolete attachments)

Reporter

Description

12 years ago
When you right click on task there is an option to change a calendar for it. But it doesn't work.
Flags: blocking-calendar0.8?
Reporter

Comment 1

12 years ago
Lt 2008011911/Tb 2.0.0.9
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12pre) Gecko/2008020521 Calendar/0.8pre

Fails for me when changing from storage to ics calendar and vice versa.

Works for me when changing from storage to storage calendar. 
In this case I see the following warning in Venkman:

Warning "reference to undefined property this.todoPromotedProps[name]'' [-s] in file "file:///E:/sunbird/js/calTodo.js'', line 238, character 0.
This does not block the 0.8 release.
Flags: blocking-calendar0.8? → blocking-calendar0.8-
Assignee

Comment 4

12 years ago
Apart from the described behaviouur I am myself not content with the implementation of that context menu because it offers calendars that are not writable for the user unlike in the calendar-event-dialog.
Assignee

Comment 5

12 years ago
Posted patch patch v. 1 (obsolete) — Splinter Review
This patch should improve the situation. In this patch I consolidated the sourcecode from the sun-calendar-event-dialog and filled up the menu only with writable calendars.
Assignee: nobody → Berend.Cornelius
Status: NEW → ASSIGNED
Attachment #303007 - Flags: review?
Assignee

Comment 6

12 years ago
Posted patch patch v. 1 (obsolete) — Splinter Review
This patch should improve the situation. In this patch I consolidated the sourcecode from the sun-calendar-event-dialog and filled up the menu only with writable calendars.
Attachment #303008 - Flags: review?(philipp)
Attachment #303007 - Attachment is obsolete: true
Attachment #303007 - Flags: review?
Flags: blocking-calendar0.8- → blocking-calendar0.8+
Assignee

Comment 7

12 years ago
Posted patch patch v. #2Splinter Review
I added a small change because I saw that I was not comparing calendars by their ids. This new patch also fixes bug 416584 on the way. I hope it's Ok when I set the other issue - that occured because the calendar was not set at the item - to 'duplicate' to this one.
Attachment #303008 - Attachment is obsolete: true
Attachment #303052 - Flags: review?(philipp)
Attachment #303008 - Flags: review?(philipp)
Blocks: 416584
Comment on attachment 303052 [details] [diff] [review]
patch v. #2


>+        var selIndex = appendCalendarItems(tasks[0], calendarMenuPopup, "contextChangeTaskCalendar(event);"); //, command);
>+        if (isPropertyValueSame(tasks, "calendar") && (selIndex > -1)) {
>+            calendarMenuPopup.childNodes[selIndex].setAttribute("checked", "true");
>+        }
Remove the //, command comment. 


>  * Contributor(s):
>+ *                 Berend Cornelius <berend.cornelius@sun.com>
Please align your name under the n of Contributors



>+/** checks if an item is supported by a Calendar
>+* @param aCalendar the calendar
>+* @param aItem the item either a task or an event
>+* @return true or false
>+*/
It would be great if you could format the comments as in the other files we have them: Newline after /**, Empty line after description, and aligned parameter descriptions. Example follows. Please fix here and elsewhere.

/**
 * Checks if an item is supported by a calendar
 *
 * @param aCalendar    The Calendar
 * @param aItem        the item, either a task or an event. This
 *                       would happen if the description needs
 *                       to be wrapped.
 * @return             True if the item is supported
 */


>Index: prototypes/wcap/sun-calendar-event-dialog.js
>===================================================================
Why do you undo the capabilities changes in this file? I think this is not intended? While



r=philipp with comments addressed
Attachment #303052 - Flags: review?(philipp) → review+
Assignee

Comment 9

12 years ago
I checked in the patch on trunk and MOZILLA_1_8_BRANCH. I adressed the issues of philipp.
>Why do you undo the capabilities changes in this file? I think this is not
>intended? While
I don't quite understand what you mean as I did not undo these changes. I just shifted them to calUtils.js. Before I set the issue to "Fixed" we should probably get clear on that.
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → 0.8
Version: Mozilla 1.8 Branch → unspecified
Depends on: 417508
This checkin broke the event/task dialog, see Bug 417508.
I see what you mean. Setting this to fixed since I have a patch attached to the regression fix bug.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED

Comment 12

12 years ago
Checked in nightly build 2008022018 -> task is fixed and verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.