Ability to use old-style URL auto-completion in address-bar

RESOLVED WORKSFORME

Status

()

--
enhancement
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: jaroslav.zaruba, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: See comment #10 to achieve this with prefs)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2

Let user switch to the old-style URL auto-completion in address-bar; so that only URLs are used.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
when I type "mp3" in the address-bar I get "123mp3.tld" in the first place instead of "mp3.tld"

Expected Results:  
when I type "mp3" in the address-bar I get "mp3.tld" in the first place
(Reporter)

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 1

11 years ago
Sorry, for a while I assumed browser.urlbar.richResults solves this but it seems to me to do nothing...
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 2

11 years ago
FF needs to get restarted
i'm sorry again :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → INVALID
fwiw browser.urlbar.richResults has been removed post-3.0b2
disabling the awesomebar and returning to the old style autocomplete is something best left to an extension.
Status: RESOLVED → VERIFIED

Updated

11 years ago
Duplicate of this bug: 422610

Comment 6

11 years ago
oldbar extension doesn't fix the problem.
it changes only the appearance.
Duplicate of this bug: 422610
Even if there is an extension that does just this, that doesn't make this bug INVALID. If this feature isn't wanted in Firefox, WONTFIX is the correct resolution. Reopening.
Status: VERIFIED → UNCONFIRMED
OS: Windows 2000 → All
Hardware: x86 → All
Resolution: INVALID → ---
Version: unspecified → Trunk
fwiw, this feature can be restored by changing the pref browser.urlbar.matchBehavior to 3, although it will still search through page titles. See http://kb.mozillazine.org/Browser.urlbar.matchBehavior .

Comment 10

10 years ago
Try this in Firefox 3.5 Edit -> Preferences, "Privacy" section, at the bottom for "when using the location bar, suggest:" choose "History" from the dropdown.
In about:config do the following
Change the value of browser.urlbar.matchBehavior to 3
Change the value of browser.urlbar.default.behavior to 17
Change the values of both browser.urlbar.match.url and browser.urlbar.restrict.typed to empty strings

Updated

10 years ago
Whiteboard: See comment #10 to achieve this with prefs
This WORKSFORME by changing preferences (see comment 10).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago10 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Duplicate of this bug: 409895
You need to log in before you can comment on or make changes to this bug.