Firefox icon is fuzzy/blurry (enlarged from tiny version?)

VERIFIED FIXED in Firefox 3 beta3

Status

()

Firefox
Shell Integration
VERIFIED FIXED
10 years ago
4 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

({polish})

Trunk
Firefox 3 beta3
x86
Linux
polish
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Between 2008-01-18-04-trunk and 2008-01-19-04-trunk the Firefox icon that I see when Alt-tabbing between windows or when Ctrl-Shift-Arrowing between workspaces is fuzzy.  It looks like it's being enlarged from a very small size icon.  Presumably this is a regression from bug 412049.

Steps to reproduce:
 1. Start Minefield on Linux under GNOME
 2. Use Alt+Tab to switch between windows
 3. Use Ctrl-Shift-arrows to switch between workspaces

Expected results: crisp-looking icon
Actual results: fuzzy-looking icon

Bug NOT present in:
  Linux nightly 2008-01-18-04-trunk
  My own --enable-official-branding build from a few days ago

Bug present in:
  Linux nightly 2008-01-19-04-trunk
  My own --enable-official-branding build from today.
Flags: blocking-firefox3?
Created attachment 298200 [details]
screenshot of Alt-Tab popup

This is a screenshot of the popup that shows up in the middle of the screen when doing Alt+Tab.  The left icon is from the 2008-01-18-04-trunk nightly; the middle icon is from my own --enable-official-branding debug build; the right icon is from the 2008-01-19-04-trunk nightly.
Created attachment 298201 [details]
screenshot of workspace-switching popup

This is a screenshot of the workspace-switching popup (Ctrl+Alt+arrows).  Note the crisp Minefield icon in workspace 4, the crisp Sunbird icon in workspace 5, the crisp Thunderbird icon in workspace 10.  Compare that to the fuzzy Minefield icon in workspace 9, and the fuzzy Firefox icon in workspaces 2, 3, 7, and 8.  (Workspaces numbered starting from 1, the direction used for written English.)
Summary: Firefox icon is fuzzy (enlarged from tiny version?) → Firefox icon is fuzzy/blurry (enlarged from tiny version?)
Yeah, this would be expected. 412049 replaced the 48x48 XPM with a 16x16 PNG. Bug 
404402 is for adding additional resolutions, but needed this work done first. (Bug 410215 added support for multiple resolution PNGs, they just need to be added now.)

We should probably dupe this to 404402, and mark that as blocking / increase priority?

Updated

10 years ago
Keywords: polish

Updated

10 years ago
Duplicate of this bug: 414085
This should now be fixed, by the checkin of the 48x48 icons in bug 404402.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 beta3

Comment 6

10 years ago
Please re-open this bug, taskbar icon is now regressed and looks corrupted now. I will attach a screenshot.

Comment 7

10 years ago
Hmm looks like I am not allowed to attach a screenshot, so check out http://cekirdek.pardus.org.tr/~ismail/tmp/taskbar.png Note that firefox image is almost missing but a little bit of it is there. I also see image corruptions.
You're describing something different than what this bug was about, and the images work fine in my build. I'd tend to suspect a bug in whatever task switcher you're using; perhaps it's confused by there being multiple images and is only copying 16x16 worth of data from the 48x48 bitmap. File a new bug and mark it as blocking bug 404402, which is the bug that changed the icons.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Flags: blocking-firefox3? → blocking-firefox3+
You need to log in before you can comment on or make changes to this bug.