Closed Bug 412049 Opened 12 years ago Closed 12 years ago

Use PNG instead of XPM for default window icon on Linux

Categories

(Firefox :: General, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 3 beta3

People

(Reporter: Dolske, Assigned: Dolske)

References

Details

Attachments

(2 files, 1 obsolete file)

Attached patch Patch v.1 for review (obsolete) — Splinter Review
PM is a crufty old format. Bug 410215 describes some problems with it, and landed a change to allow using PNG images instead.

As a first step towards fixing bug 404402, we should replace the existing XPM with a PNG. That bug can then add optimized versions for different sizes as needed.

This patch replaces default.xpm with default16.png. I went ahead and included the change for XUL Runner here too, since it uses the same generic "globe" icon as unbranded Firefox.
Attachment #296666 - Flags: ui-review?(mconnor)
Attachment #296666 - Flags: review?(mconnor)
Attachment #296666 - Attachment is patch: true
Attachment #296666 - Attachment mime type: application/octet-stream → text/plain
Attachment #296666 - Flags: review?(benjamin)
Attached file Icons added
Attachment #296666 - Flags: ui-review?(mconnor)
Attachment #296666 - Flags: ui-review+
Attachment #296666 - Flags: review?(mconnor)
Attachment #296666 - Flags: review+
Duplicate of this bug: 412078
Duplicate of this bug: 242051
Firefox shouldn't use specified PNG, but icon from icon theme.
Comment on attachment 296666 [details] [diff] [review]
Patch v.1 for review

>Index: browser/app/Makefile.in

> install::
>-	$(SYSINSTALL) $(IFLAGS1) $(DIST)/branding/default.xpm $(DESTDIR)$(mozappdir)/chrome/icons/default
>+	$(SYSINSTALL) $(IFLAGS1) $(DIST)/branding/default16.png $(DESTDIR)$(mozappdir)/chrome/icons/default

Please remove this and the install targets you touched altogether, because we no longer use in-tree install targets.
Attachment #296666 - Flags: review?(benjamin) → review+
Attached patch Patch v.2Splinter Review
Updated with review comments.
Attachment #296666 - Attachment is obsolete: true
Attachment #297860 - Flags: approval1.9?
Attachment #297860 - Flags: approval1.9? → approval1.9+
What about including Firefox' icon in /usr/share/icons/hicolor and using "firefox" using from icon theme (which always inherits hicolor)?

Even when using PNG as icon, when I press Alt+Tab, I'll see blurry 16x16 PNG resized to higher size, eg 32x32 or 48x48.
Checked in.

Checking in browser/app/Makefile.in;
  new revision: 1.141; previous revision: 1.140
Removing browser/app/default.xpm;
  new revision: delete; previous revision: 1.2
Checking in browser/app/default16.png;
  initial revision: 1.1
Checking in browser/branding/unofficial/Makefile.in;
  new revision: 1.4; previous revision: 1.3
Removing browser/branding/unofficial/default.xpm;
  new revision: delete; previous revision: 1.1
Checking in browser/branding/unofficial/default16.png;
  initial revision: 1.1
Checking in browser/installer/unix/packages-static;
  new revision: 1.141; previous revision: 1.140
Checking in other-licenses/branding/firefox/Makefile.in;
  new revision: 1.24; previous revision: 1.23            
Removing other-licenses/branding/firefox/default.xpm;
  new revision: delete; previous revision: 1.3
Checking in other-licenses/branding/firefox/default16.png;
  initial revision: 1.1
Checking in xulrunner/app/Makefile.in;
  new revision: 1.33; previous revision: 1.32
Removing xulrunner/app/default.xpm;
  new revision: delete; previous revision: 1.1
Checking in xulrunner/app/default16.png;
  initial revision: 1.1
Status: NEW → RESOLVED
Closed: 12 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
(In reply to comment #7)
> What about including Firefox' icon in /usr/share/icons/hicolor and using
> "firefox" using from icon theme (which always inherits hicolor)?

This bug is about simply replacing the existing XPM usage with PNG. If you want to change other things regarding the window icon, file a new bug (or find some existing bug covering your concern).
(In reply to comment #7)
> Even when using PNG as icon, when I press Alt+Tab, I'll see blurry 16x16 PNG
> resized to higher size, eg 32x32 or 48x48.

This is because this patch only adds default16.png, I guess bug 404402 is about providing other sizes, such as SeaMonkey has done in bug 411494
You need to log in before you can comment on or make changes to this bug.