"ASSERTION: PostRestyleEvent after the shell is destroyed (bug 279505)" with <style> in <svg:use>

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Jesse Ruderman, Assigned: mats)

Tracking

(Blocks: 2 bugs, {assertion, regression, testcase})

Trunk
assertion, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Loading the testcase triggers:

###!!! ASSERTION: PostRestyleEvent after the shell is destroyed (bug 279505): 'Not Reached', file /Users/jruderman/trunk/mozilla/layout/base/nsCSSFrameConstructor.cpp, line 13277

This assertion was added in bug 279505.  (I don't understand why the patch added the assertion -- doesn't the testcase for that bug trigger the assertion too?)
(Reporter)

Comment 1

11 years ago
Created attachment 298638 [details]
testcase
(Reporter)

Updated

11 years ago
Blocks: 279505
The assert was added because on trunk we shouldn't be hitting it, in fact.  I don't believe we hit it on that testcase...

Mats, want to either fix this, or make it safe to do this sort of thing?
Probably the former, I would guess...
(Assignee)

Comment 4

11 years ago
Created attachment 298650 [details]
stack

This is a false alarm.  I forgot that we temporarily set
mIsDestroyingFrameTree true while destroying the root frame:
http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/layout/base/nsCSSFrameConstructor.cpp&rev=1.1457&root=/cvsroot&mark=7818#7799
(Assignee)

Updated

11 years ago
Assignee: nobody → mats.palmgren
OS: Mac OS X → All
Hardware: PC → All
(Reporter)

Comment 5

9 years ago
WFM on trunk.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

9 years ago
Crashtest: http://hg.mozilla.org/mozilla-central/rev/b64a7e4a35e2
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.