Misleading resume/retry on a POST-submitted download

VERIFIED DUPLICATE of bug 401846

Status

()

VERIFIED DUPLICATE of bug 401846
11 years ago
10 years ago

People

(Reporter: stephend, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
Build ID: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b3pre) Gecko/2008012204 Minefield/3.0b3pre

Summary: Misleading resume/retry on a POST-submitted download

Steps to Reproduce:

1. Load http://uploaded.to/?id=g3yavo (or many of the files linked to these free-download services off http://www.alldj.org)
2. Click "Download", which kicks off a POST submit

Actual Results:

See screenshot

Expected Results:

We shouldn't offer the user the option to resume/retry the download, should we?
Flags: blocking-firefox3?
(Reporter)

Comment 1

11 years ago
Screenshot: http://img151.imageshack.us/my.php?image=picture5dn0.png

I split this off from bug 410289, to keep things cleaner.
(Reporter)

Comment 2

11 years ago
Whoa, Batman; half-submitted comments--

Here are the full steps, sorry:

Steps to Reproduce:
 
1. Load http://uploaded.to/?id=g3yavo (or many of the files linked to these free-download services off http://www.alldj.org)
2. Click "Download", which kicks off a POST submit
3. Click "Pause"
4. Click "Resume"

Comment 3

11 years ago
The form is a POST submission but it redirects to a GET. Should be the same issue as bug 401846.

sdwilsh: If you're curious, the entity id was "/106293192/" something like that (the number is the file size).
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 401846
(Reporter)

Comment 4

11 years ago
Verified dup
Status: RESOLVED → VERIFIED
Flags: blocking-firefox3?
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.