[Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]" nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)" location: "JS frame :: chrome://browser/content/utilityOverlay.js :: getShellS

RESOLVED DUPLICATE of bug 383348

Status

()

RESOLVED DUPLICATE of bug 383348
11 years ago
11 years ago

People

(Reporter: matt, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Created attachment 298675 [details]
C/C++ stack trace

On startup the debug build gives me this exception:

[Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://browser/content/utilityOverlay.js :: getShellService :: line 285"  data: no]

The JS stack (minus undefined vars) was:

0 getShellService() ["chrome://browser/content/utilityOverlay.js":286]
    shell = null
    this = [object ChromeWindow @ 0x84230b0 (native @ 0x8421ef4)]
1 delayedStartup(1032) ["chrome://browser/content/browser.js":803]
    os = [xpconnect wrapped nsIObserverService @ 0x8694c98 (native @ 0x8109d30)]
    this = [object ChromeWindow @ 0x84230b0 (native @ 0x8421ef4)]
This sounds like a duplicate of bug 383348. Do you have those gnome libraries available?
(Reporter)

Comment 2

11 years ago
Oops, it *is* a dup of bug bug 383348.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 383348
You need to log in before you can comment on or make changes to this bug.