Firefox popup blocker triggered on clicks in Flash plugin Version 9.0. r115 but not older Flash plugins

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
11 years ago
5 years ago

People

(Reporter: Brian 'netdragon' Bober, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
I filed this on Adobe's bug reporting system as well, since it was brought on by a change between component versions, but may indicate a situation where Firefox's popup blocker may be too aggressive. Generally, in the past, popups weren't blocked when using .onRelease or on(release) to handle a click event in Flash and load a popup since Firefox somehow linked these to the clicks (except in cases where there was too much of a delay).

I'm assuming the correct component for this is plugins.

Version 9.0. r115 causes Firefox popup blocking to be triggered for getURL( ... , "_blank") in some cases that weren't blocked for previous versions of the Flash plugin (e.g. 9.0 r47). This includes SWFs loaded into a movie clip, even when using on(release) or .onRelease.
Steps to reproduce bug:
 1. Install Flash plugin 9.0.115.0
 2. Grab FLAs (for Flash CS3) at http://apps.eyewonderlabs.com/adWdrVideoSpace/ad/test/brian/instream/flash%5Fin%5Fflash%5Fpopup%5Fblocking%5F115/_adobebugreport/testcase_fla.zip
 3. Publish test_ad.fla and place SWF on a server
 4. Hardcode frame 1 "actions" layer line 37 to use the SWF URL you published in step 2
 5. Publish testcase_player.swf to the same  server directory.
 6. Create HTML page to load testcase_player.swf with allowscriptaccess set to "always"
 7. Load HTML page. E.g. http://apps.eyewonderlabs.com/adWdrVideoSpace/ad/test/brian/instream/flash%5Fin%5Fflash%5Fpopup%5Fblocking%5F115/_adobebugreport/testcase_player.html
 Results: Clicking on "Click here to test" gets popup blocked in 9.0 r115. Being able to click through is an integral part of online advertising.

Expected results: Popup shouldn't be blocked since it wasn't blocked with 9.0 r47
(Reporter)

Comment 2

11 years ago
I have more details based on testing.

Cause:
This issue occurs when wmode is set to "window" (or not set to anything) for the embed statement and the following is also true:
 * Flash version: Doesn't affect anything newer than 9.0.115.0 
 * Only affects Windows, not Mac
 * Browser version being used: FF 2.0.0.11
 * Only affects when the HTML that embeds the player is served on-line (local copies not affected)

If wmode is changed to "opaque" or "transparent", the issue goes away.
(Reporter)

Comment 3

11 years ago
Sorry, a correction on comment #2. Flash version should read: Doesn't affect anything _OLDER_ than 9.0.115.0 (Nothing newer than 9.0.115.0 has been released yet :-) )

Comment 4

11 years ago
Thanks for bringing this issue to our attention. The Flash Player team will investigate.
(Reporter)

Comment 5

11 years ago
Thanks Michelle.

By the way, some additional notes for people who rely on fullscreen functionality: If you change wmode to "opaque", fullscreen will only work in 9.0.115.0 and later, so I found a solution is to do flash plugin version sniffing and use "window" for anything less than 9.0.115.0.

Other considerations from changing wmode to "opaque" is that "window" has slightly higher performance. There may be other considerations but that's all I know of.

Updated

11 years ago
Duplicate of this bug: 411138

Comment 7

11 years ago
The Flash Player team has fixed this bug internally and it will be released in a future version of the Flash Player. Thanks again for the bug report!

Comment 8

10 years ago
This bug is now fixed in the Flash Player 10 beta: http://labs.adobe.com/downloads/flashplayer10.html

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.