If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Bookmark This Link" doesn't show popup UI

RESOLVED DUPLICATE of bug 414837

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 414837
10 years ago
8 years ago

People

(Reporter: Gomita, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9b3pre) Gecko/2008013004 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9b3pre) Gecko/2008013004 Minefield/3.0b3pre

Right-click -> 'Bookmark This Page' results in:

Error: this.showEditBookmarkPopup is not a function
Source File: chrome://browser/content/browser.js
Line: 5582

Reproducible: Always

Steps to Reproduce:
1.right-click on a link
2.select "Bookmark This Link"
Actual Results:  
The link is bookmarked without showing popup UI.

Expected Results:  
Shows popup UI.
(Reporter)

Updated

10 years ago
Depends on: 393509
(Reporter)

Comment 1

10 years ago
Needs to change the following line of PlacesCommandHook.bookmarkLink.
- this.showEditBookmarkPopup
+ StarUI.showEditBookmarkPopup

Comment 2

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 414837
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.