Closed Bug 415390 Opened 14 years ago Closed 14 years ago

refreshing a livebookmark in a bookmark menu's submenu throws 'Container view not found'

Categories

(Firefox :: Bookmarks & History, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Firefox 3 beta4

People

(Reporter: ht990332, Assigned: mano)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2008020300 Firefox/3.0b3pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2008020300 Firefox/3.0b3pre

Reloading a a live bookmark doesn't do anything and it spits out a lot of these errors in error console when I try to reload a live bookmark.

Error: [Exception... "'Container view not found' when calling method: [nsINavHistoryResultViewer::itemRemoved]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: file:///usr/lib/firefox/components/nsPlacesTransactionsService.js :: PSSFBN_doTransaction :: line 856"  data: no]
Source File: file:///usr/lib/firefox/components/nsPlacesTransactionsService.js
Line: 856

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
This was working in my previous cvs build on 20080201.
Version: unspecified → Trunk
Another note is that this happens only in live bookmarks in a subfolder in the 'bookmarks menu' and not in the 'bookmarks folder'
Version: Trunk → unspecified
Sorry I mean 'bookmarks toolbar' instead of 'bookmarks folder'.
Sorry for the spam and typing errors.

Last comment should be:
Another note is that this happens only in live bookmarks in a subfolder in the
'bookmarks menu' and not in the 'bookmarks toolbar'
Version: unspecified → Trunk
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2008020419 Minefield/3.0b3pre

Yep, it happens to me. Got same error
confirmed
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008020404 Minefield/3.0b3pre
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
STR:

- have a livemark into a subfolder of bookmark menu
- go to livemark into the menu, right click, Reload Live Bookmark
Flags: blocking-firefox3?
Keywords: regression
Another problem: Sorting by name from bookmarks menu (not organiser) doesn't work and spits out the same error.

There may be further breakage. If I find anything else broken with same error message, I will make sure to post it here.
could someone check if this regressed after 29/01?
Mano, the fact that it's talking about missing a container makes me wonder if this is a places thing ...
Priority: -- → P3
(In reply to comment #8)
> could someone check if this regressed after 29/01?
> 

yes, it is after 29/01 because I remember it was working for me on 20080201.
Flags: blocking-firefox3? → blocking-firefox3+
after checking that this was working in 28/01 build i suppose another regression from Bug 412148
Attached patch move back _containerNodesMap (obsolete) — Splinter Review
this fixes the problem, however i'm not sure about the cause, Mano you probably want to fix this better or investigate on what happens here, since i don't know this code interactions so well
Attachment #302794 - Flags: review?(mano)
from what i saw, _containerNodesMap was empty when looking for the node, so it was probably resetted after being setup
Summary: refreshing a livebookmark doesn't do anything and spits out a error in error console. → refreshing a livebookmark in a bookmark menu's submenu throws 'Container view not found'
(In reply to comment #12)
> Created an attachment (id=302794) [details]
> move back _containerNodesMap
> 
> this fixes the problem, however i'm not sure about the cause, Mano you probably
> want to fix this better or investigate on what happens here, since i don't know
> this code interactions so well
> 

you patch also fixes the issue I mentioned in Comment #7   ;)
maybe causing bug 407192.
Yes same bug because Marco Bonardo's patch also fixes bug 407192 for me.
Blocks: 407192
Target Milestone: --- → Firefox 3 beta4
Whiteboard: [needs review mano]
Blocks: 417471
Blocks: 417490
while working at drop marker on the bookmarks menu i found that containerNodesMap in "set result()" is cleared when right clicking on the menu item (the livemark)...
more generally, set result is called every time i right click on a Container, so the nodesMap is cleared while it should not
Attachment #302794 - Flags: review?(mano)
Whiteboard: [needs review mano] → [has workaround]
here is a stack printed with NS_ASSERT when that happens:

ASSERT: undefined
Stack Trace: 
0:([xpconnect wrapped nsINavHistoryResult])
1:viewer([xpconnect wrapped nsINavHistoryResultViewer])
2:PU_getURLsForContainerNode([xpconnect wrapped (nsISupports, nsINavHistoryResultNode, nsINavHistoryContainerResultNode, nsINavHistoryQueryResultNode)])
3:PC_buildContextMenu([object XULElement])
4:buildContextMenu([object XULElement])
5:onpopupshowing([object MouseEvent])
Attachment #302794 - Attachment is obsolete: true
Attached patch patchSplinter Review
Assignee: nobody → mano
Status: NEW → ASSIGNED
Attachment #304370 - Flags: review?(dietrich)
Attachment #304370 - Flags: review?(dietrich) → review+
mozilla/browser/components/places/content/menu.xml 1.100
mozilla/browser/components/places/content/toolbar.xml 1.122
mozilla/browser/components/places/content/treeView.js 1.39
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Whiteboard: [has workaround]
Blocks: 418212
Duplicate of this bug: 415193
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.