Source viewer needs menu icons

VERIFIED FIXED in Firefox 3 beta5

Status

()

Firefox
Theme
--
trivial
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Andrés Delfino, Assigned: Ian Spence)

Tracking

Trunk
Firefox 3 beta5
x86
Linux
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2008020413 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2008020413 Minefield/3.0b3pre

Firefox main window menus has icons that can (and should) be used in Source viewer:

File ▸ Save Page As...
File ▸ Print Preview
File ▸ Print...
File ▸ Close

Edit ▸ Undo
Edit ▸ Redo
Edit ▸ Cut
Edit ▸ Copy
Edit ▸ Paste
Edit ▸ Delete
Edit ▸ Select All
Edit ▸ Find
Edit ▸ Find Again

View ▸ Reload

Help ▸ Help Contents
Help ▸ About Minefield

Reproducible: Always
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk
(Reporter)

Updated

10 years ago
Flags: blocking-firefox3?
(Reporter)

Comment 1

10 years ago
Also include context menu items.
This does not block the final release of Firefox 3.
Status: UNCONFIRMED → NEW
Component: View Source → Theme
Ever confirmed: true
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3-
QA Contact: view.source → theme
Blocks: 405165
(Assignee)

Updated

10 years ago
Duplicate of this bug: 421723
(Assignee)

Comment 4

10 years ago
I'm not even sure this is possible without some ugly hacking.  The stylesheet for view source is not part of the standard theme hierarchy, so I don't think it can be styled.

The other option would be throwing all that style stuff into the only other file included by the source file, and that's global.css

The other, best theoretical option is to just add a stylesheet to each of the themes called viewSource.css that could contain this, but I wonder if there is a reason this is the only dialog not styled by themes
(Reporter)

Comment 5

10 years ago
IMHO, having a viewSource.css would be the best solution, but I don't know how hard would it be to change this.

I guess themes don't care about the View source window, but system integration does :P
(Assignee)

Comment 6

10 years ago
Created attachment 309633 [details] [diff] [review]
Add menu icons to the View Source dialog

This is my first attempt at a fix.  I wasn't sure where the file should go, so I threw it into toolkit/themes/[theme]/mozapps/viewsource (a directory I created)

I didn't move the styling for the syntax highlighting in there since I don't think we need to make that part of every theme, but I made sure that I include this file in the page after the syntax highlighting file so that themes, if they wnated to, could override the highlighting
Assignee: nobody → ispence
Status: NEW → ASSIGNED
Attachment #309633 - Flags: review?(mano)
Comment on attachment 309633 [details] [diff] [review]
Add menu icons to the View Source dialog

>+        skin/classic/aero/viewsource/viewsource.css                        (viewsource/viewsource.css)

This is missing a "mozapps/" in the path.
(Assignee)

Comment 8

10 years ago
Created attachment 309680 [details] [diff] [review]
Updated to support Vista

Alas, Roc has thwarted my plan to destroy Vista from the inside.  I've updated my patch accordingly
Attachment #309633 - Attachment is obsolete: true
Attachment #309680 - Flags: review?(mano)
Attachment #309633 - Flags: review?(mano)
Comment on attachment 309680 [details] [diff] [review]
Updated to support Vista

Please add ids to styled menu-items instead. The non-stub style file should include a license header.
Attachment #309680 - Flags: review?(mano) → review-
(Assignee)

Comment 10

10 years ago
Created attachment 309705 [details] [diff] [review]
Addresses comments

Uses ids instead of cmd attributes and adds a license header to the gnomestripe css file
Attachment #309680 - Attachment is obsolete: true
Attachment #309705 - Flags: review?(mano)
Comment on attachment 309705 [details] [diff] [review]
Addresses comments

r=mano
Attachment #309705 - Flags: review?(mano) → review+
Attachment #309705 - Flags: approval1.9?
Comment on attachment 309705 [details] [diff] [review]
Addresses comments

a1.9=beltzner
Attachment #309705 - Flags: approval1.9? → approval1.9+
Keywords: checkin-needed
Checking in toolkit/components/viewsource/content/viewPartialSource.xul;
/cvsroot/mozilla/toolkit/components/viewsource/content/viewPartialSource.xul,v  <--  viewPartialSource.xul
new revision: 1.29; previous revision: 1.28
done
Checking in toolkit/components/viewsource/content/viewSource.xul;
/cvsroot/mozilla/toolkit/components/viewsource/content/viewSource.xul,v  <--  viewSource.xul
new revision: 1.37; previous revision: 1.36
done
Checking in toolkit/themes/gnomestripe/mozapps/jar.mn;
/cvsroot/mozilla/toolkit/themes/gnomestripe/mozapps/jar.mn,v  <--  jar.mn
new revision: 1.11; previous revision: 1.10
done
RCS file: /cvsroot/mozilla/toolkit/themes/gnomestripe/mozapps/viewsource/viewsource.css,v
done
Checking in toolkit/themes/gnomestripe/mozapps/viewsource/viewsource.css;
/cvsroot/mozilla/toolkit/themes/gnomestripe/mozapps/viewsource/viewsource.css,v  <--  viewsource.css
initial revision: 1.1
done
Checking in toolkit/themes/pinstripe/mozapps/jar.mn;
/cvsroot/mozilla/toolkit/themes/pinstripe/mozapps/jar.mn,v  <--  jar.mn
new revision: 1.27; previous revision: 1.26
done
RCS file: /cvsroot/mozilla/toolkit/themes/pinstripe/mozapps/viewsource/viewsource.css,v
done
Checking in toolkit/themes/pinstripe/mozapps/viewsource/viewsource.css;
/cvsroot/mozilla/toolkit/themes/pinstripe/mozapps/viewsource/viewsource.css,v  <--  viewsource.css
initial revision: 1.1
done
Checking in toolkit/themes/winstripe/mozapps/jar.mn;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/jar.mn,v  <--  jar.mn
new revision: 1.32; previous revision: 1.31
done
RCS file: /cvsroot/mozilla/toolkit/themes/winstripe/mozapps/viewsource/viewsource.css,v
done
Checking in toolkit/themes/winstripe/mozapps/viewsource/viewsource.css;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/viewsource/viewsource.css,v  <--  viewsource.css
initial revision: 1.1
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 beta5

Comment 14

10 years ago
Help -> Help Contents in main menu of browser has an icon
but one of source viewer doesn't have.
Is this missed?
(Reporter)

Comment 15

10 years ago
Reopening per comment 14.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 16

10 years ago
Created attachment 310748 [details]
Source viewer Help menu lacking Help Contents icon.
(Assignee)

Comment 17

10 years ago
Created attachment 310754 [details] [diff] [review]
Adds an id to the Help Contents menuitem

Quick fix that adds an id to the Help Contents menuitem
Attachment #310754 - Flags: review?(mano)
Comment on attachment 310754 [details] [diff] [review]
Adds an id to the Help Contents menuitem

r=mano
Attachment #310754 - Flags: review?(mano)
Attachment #310754 - Flags: review+
Attachment #310754 - Flags: approval1.9?
Comment on attachment 310754 [details] [diff] [review]
Adds an id to the Help Contents menuitem

Literally just adds an id to a menuitem so the menu icon shows up.
Attachment #310754 - Flags: approval1.9b5?
Comment on attachment 310754 [details] [diff] [review]
Adds an id to the Help Contents menuitem

a=beltzner, whatever
Attachment #310754 - Flags: approval1.9b5?
Attachment #310754 - Flags: approval1.9b5+
Attachment #310754 - Flags: approval1.9?
Attachment #310754 - Flags: approval1.9+
Keywords: checkin-needed
Checking in browser/base/content/baseMenuOverlay.xul;
/cvsroot/mozilla/browser/base/content/baseMenuOverlay.xul,v  <--  baseMenuOverlay.xul
new revision: 1.18; previous revision: 1.17
done
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Blocks: 381206
(Reporter)

Updated

10 years ago
Status: RESOLVED → VERIFIED
Attachment 310754 [details] [diff] was backed out by bug 423486, so it needs to be relanded.
Keywords: checkin-needed
(Assignee)

Comment 23

10 years ago
The patch likely won't apply due to the bitrot caused by that bug.
(In reply to comment #23)
> The patch likely won't apply due to the bitrot caused by that bug.

Not a problem. I can manually fix it. :)
Checking in browser/base/content/baseMenuOverlay.xul;
/cvsroot/mozilla/browser/base/content/baseMenuOverlay.xul,v  <--  baseMenuOverlay.xul
new revision: 1.20; previous revision: 1.19
done
Keywords: checkin-needed

Comment 26

10 years ago
(In reply to comment #6)
> This is my first attempt at a fix.  I wasn't sure where the file should go, so
> I threw it into toolkit/themes/[theme]/mozapps/viewsource (a directory I
> created)
IMHO chrome://global/content/view*.xul should use global themes only...
(In reply to comment #26)
> IMHO chrome://global/content/view*.xul should use global themes only...

File a bug on moving it?
You need to log in before you can comment on or make changes to this bug.