Last Comment Bug 415775 - ClearControllers() called after global scope torn down?
: ClearControllers() called after global scope torn down?
Status: RESOLVED INVALID
: assertion, regression
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://developer.mozilla.org/En/DOM/W...
Depends on: 456696 456672 456694 456860
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-05 07:31 PST by neil@parkwaycc.co.uk
Modified: 2008-09-26 15:22 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description neil@parkwaycc.co.uk 2008-02-05 07:31:24 PST
Steps to reproduce problem:
1. Open SeaMonkey Mail (problem may also occur with Thunderbird)
2. Close the window

Actual result: ###!!! ASSERTION: XPConnect is being called on a scope without a 'Components' property!

Stack trace:
Break
NS_DebugBreak_P
DEBUG_CheckForComponentsInScope
XPCWrappedNativeScope::FindInJSObjectScope
GetContextFromObject
nsXPCWrappedJSClass::DelegatedQueryInterface
nsXPCWrappedJS::QueryInterface
nsXPTCStubBase::QueryInterface
nsQueryInterface::operator()
nsCOMPtr<nsIControllerContext>::assign_from_qi
nsCOMPtr<nsIControllerContext>::nsCOMPtr<nsIControllerContext>
nsGlobalWindow::ClearControllers() nsCOMPtr<nsIControllerContext> context = do_QueryInterface(controller);
nsGlobalWindow::SetDocShell ClearControllers();
docshell.dll!nsDocShell::Destroy win->SetDocShell(nsnull);
nsXULWindow::Destroy shellAsWin->Destroy();
nsWebShellWindow::Destroy return nsXULWindow::Destroy();
[rest of stack looked irrelevant]
Comment 1 Boris Zbarsky [:bz] (Out June 25-July 6) 2008-02-05 11:36:27 PST
This doesn't look like a docshell bug. Most likely DOM (global window) or xpconnect.
Comment 2 neil@parkwaycc.co.uk 2008-09-24 04:01:50 PDT
OK, so after some thought I've decided that this bug is invalid, because controllers live on the outer window, and only chrome can add and remove them. I documented that you should remove any window controllers you add.
Comment 3 Serge Gautherie (:sgautherie) 2008-09-26 15:22:15 PDT
(In reply to comment #2)
> I documented that you should remove any window controllers you add.

I added the reference to this bug/behavior to that page...

Note You need to log in before you can comment on or make changes to this bug.