Multiple keyboard shortcuts busted (eg switch tab, undo close tab)

RESOLVED FIXED in mozilla1.9beta4

Status

()

Core
Widget: Cocoa
P1
normal
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: nthomas, Assigned: Josh Aas)

Tracking

({regression})

Trunk
mozilla1.9beta4
x86
Mac OS X
regression
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b4pre) Gecko/2008020604 Minefield/3.0b4pre

In the nightly, cmd-<digit> doesn't switch tab - it just beeps. If the location bar is focused then it works.

Similarly, cmd-shift-t doesn't undo a closed tab, and cmd-shift-r doesn't completely reload a page.

This appeared between the hourly builds which started at 2223 and 2255 PST, so the regression window is
  http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1202278980&maxdate=1202280899

Perhaps bug 358379 ?
Flags: blocking1.9?
(Reporter)

Comment 1

10 years ago
Steps to reproduce cmd-<digit>:

1, Make a new profile with 2255 or later build (result: loads two tabs)
2, cmd-2 (beep! no tab switch)
3, focus the location bar
4, cmd-1 or cmd-2 (switches tab)
5, switch to blank tab, then click on content area
6, cmd-1 (beep! no tab switch)

cmd-shift-t and cmd-shift-r also work when the location bar is focused.
Target Milestone: --- → mozilla1.9beta4
Flags: blocking1.9? → blocking1.9+
Priority: -- → P1
Blocks: 358379
Duplicate of this bug: 416162

Updated

10 years ago
Duplicate of this bug: 416122

Updated

10 years ago
Duplicate of this bug: 416283
Duplicate of this bug: 416453

Comment 6

10 years ago
I'm having problems with cmd+[num] and cmd+shift+r, but cmd+shift+t works for me.

Updated

10 years ago
Duplicate of this bug: 416704

Comment 8

10 years ago
(In reply to comment #0)
> In the nightly, cmd-<digit> doesn't switch tab - it just beeps. If the location
> bar is focused then it works.

It also works if you give the search box, the actual notebook tab, or the status bar focus.  So it seems like it's broken if the page content (or any widget on it, like this bugzilla text box) has focus.
Duplicate of this bug: 416715
(Assignee)

Comment 10

10 years ago
backed out 358379
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Updated

10 years ago
Duplicate of this bug: 416803

Comment 12

10 years ago
This appears to have suffered regression in the latest nightly build.

Comment 13

10 years ago
(In reply to comment #12)
> This appears to have suffered regression in the latest nightly build.

Apparently I was mistaken; it seems that in the process of updating, something was written to my prefs.js that caused Cmd+<1-9> to stop working.  (I've no clue what, exactly; all of the differences between it and the copy on my desktop do not seem to be indicative of something that would cause this.)  Replacing my prefs.js fixed it.
You need to log in before you can comment on or make changes to this bug.