Closed Bug 415957 Opened 12 years ago Closed 12 years ago

No focus feedback for all non-native widgets in proto

Categories

(Firefox :: Theme, defect, major)

x86
macOS
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: mano, Assigned: kevin)

References

Details

(Keywords: access, regression)

Attachments

(1 file)

Both the browser-tabstrip and various non-native widget (buttons/menulists in particular, checkboxes too, very likely) has no feedback in proto/new pinstripe. This is extremely annoying in the advanced search UI in the places organizer for example, and regresses out aceessiblility story on mac just to where it was about three years ago...
Flags: blocking-firefox3?
Since both the buttons and the menulists are already not even close to the native ones, I think it'd be just fine to use images for this state too.
Keywords: access, regression
Version: unspecified → Trunk
Blocks: fox3access
Component: General → Theme
QA Contact: general → theme
Flags: blocking-firefox3? → blocking-firefox3+
Depends on: 417904
Specifically these graphics?

I can't see what you are describing in the tabbar though.
The tabs have been fixed in bug 417904.
Kevin, we need your help here...
Assignee: nobody → kevin
Depends on: 427555
This was in Proto 0.16.1 but it didn't land with the Proto changes. Kevin?
I'm pretty sure that now we have focus feedback for controls that accept focus. What are we missing?
 * The "views" button within the sidebar
Depends on: 430202
testing proto .17, it looks like the focus ring around the match case checkbox in the Find toolbar causes the checkbox and label to shift to the right a pixel or two.  other than that, things look pretty good. 
(In reply to comment #8)
> testing proto .17, it looks like the focus ring around the match case checkbox
> in the Find toolbar causes the checkbox and label to shift to the right a pixel
> or two.  other than that, things look pretty good. 
>

just uploaded Proto 0.17.2 to AMO which has the fix for the shifty checkbox 

perfect. Looks great with .17.2
fixed by checkin of Proto 0.17 changes - bug 430202
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Depends on: 476370
Keywords: sec508
You need to log in before you can comment on or make changes to this bug.