###!!! ASSERTION: Oops! You're asking for a weak reference to an object that doesn't support that.: 'factoryPtr', file nsWeakReference.cpp,

VERIFIED FIXED

Status

()

defect
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: cbook, Assigned: sicking)

Tracking

({assertion})

Trunk
x86
macOS
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(2 attachments)

Reporter

Description

11 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008020621 Firefox/3.0b4pre

Note, its the same assertion as in Bug 414808 but this is on different scenario

Steps to reproduce:
- New Firefox Profile
- Install the Session Saver Extension (this make it easier to reproduce this problem, but its not necessary) https://addons.mozilla.org/en-US/firefox/addon/2324
- go to http://www.popuptest.com/popuptest12.html
- the popup warning bar is displazed, choose "allow pop-ups for www.popuptest.com
- Reload the Site
- the 3 popup sites are displayed
 -Quit Firefox with this 3 pop up windows open

Firefox does not close and instead you get a lot of error messages and a assertion:

###!!! ASSERTION: Oops!  You're asking for a weak reference to an object that doesn't support that.: 'factoryPtr', file nsWeakReference.cpp, line 109
Flags: blocking1.9?
Reporter

Comment 1

11 years ago
Note, the problem in general here is causing also bug 416048.
Reporter

Comment 2

11 years ago
note: the same assertion comes also up when a extension is downloaded/installed with the Extension Manager.
Flags: blocking1.9? → blocking1.9+
Tomcat, can you get a stack for this assertion?
Reporter

Comment 4

11 years ago
Posted file stack
(In reply to comment #3)
> Tomcat, can you get a stack for this assertion?
> 

done :)

this stack is from the case when i install a extension with the extension manager (like going to addons.mozilla.org , choose a extension and click on install now and on "install") with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008021917 Minefield/3.0b4pre
Bummer, the stack is all JS. This definitely looks like a bug in the extension. Would be excellent with a JS stack. Ping me on irc and I can help you create one.
Mossop broke the QI impl in bug 404726
Blocks: 404726
Posted patch Obvious patchSplinter Review
Assignee: nobody → jonas
Status: NEW → ASSIGNED
Attachment #304378 - Flags: superreview?(jst)
Attachment #304378 - Flags: review?(jst)
Attachment #304378 - Flags: superreview?(jst)
Attachment #304378 - Flags: superreview+
Attachment #304378 - Flags: review?(jst)
Attachment #304378 - Flags: review+
Checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Reporter

Comment 9

11 years ago
verified fixed using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008022101 Firefox/3.0b4pre

thanks jonas !
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.