Last Comment Bug 416053 - KDE/Gnome startup notification not disappearing when app window is up
: KDE/Gnome startup notification not disappearing when app window is up
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Widget: Gtk (show other bugs)
: 1.9.1 Branch
: All Linux
: -- normal (vote)
: mozilla2.0
Assigned To: Wolfgang Rosenauer [:wolfiR]
:
Mentors:
: 425934 (view as bug list)
Depends on: 534845
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-06 19:21 PST by Robert Kaiser (not working on stability any more)
Modified: 2010-07-15 14:45 PDT (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
.4-fixed


Attachments
patch f(rom Lubos Lunak) (1.91 KB, patch)
2009-10-07 04:48 PDT, Wolfgang Rosenauer [:wolfiR]
benjamin: review+
mbeltzner: approval1.9.2.4+
Details | Diff | Review

Description Robert Kaiser (not working on stability any more) 2008-02-06 19:21:52 PST
For probably as long as I can remember using 1.9 trunk builds (I guess some time around the switch of SeaMonkey to toolkit), the KDE startup notification (jumping app icon next to the mouse) does not disappear when the (first) app window is open, it only goes way after some timeout. This looks like the desktop never realizes our window is actually up.
Interestingly, this has been working on branch, where we AFAIK don't specifically support the freedesktop startup notification stuff.
Comment 1 Patrice T 2008-04-16 11:38:18 PDT
I had the same problem:

You need to compile Firefox with the startup-notification library.
(--enable-startup-notification)

Voilà! fixed ;)
Bye.
Comment 2 Stroker 2008-12-04 13:07:33 PST
Why are the binary releases not being compiled with --enable-startup-notification?

This is a problem due to some distro's simply repacking the Mozilla release binaries, e.g., Slackware.
Comment 3 Wolfgang Rosenauer [:wolfiR] 2009-07-02 03:57:31 PDT
Probably that bug could be morphed as apparently startup notification on Linux is broken with Gecko 1.9.1. At least I see it non working with FF3.5 in Gnome and KDE even when built with --enable-startup-notification.

What do other people see?
Comment 4 Robert Kaiser (not working on stability any more) 2009-07-02 04:11:58 PDT
I never saw it working at least with 1.9.1 on KDE 3.x or 4.x, but I never tried GNOME, all on openSUSE Factory and stable 11.x releases and all with self-compiled builds which have --enable-startup-notification.
Comment 5 Wolfgang Rosenauer [:wolfiR] 2009-07-02 04:16:10 PDT
It worked with Firefox 3 but not FF3.5.
Comment 6 Aaron Slunt 2009-09-13 18:01:55 PDT
*** Bug 425934 has been marked as a duplicate of this bug. ***
Comment 7 Wolfgang Rosenauer [:wolfiR] 2009-10-07 04:48:51 PDT
Created attachment 405030 [details] [diff] [review]
patch f(rom Lubos Lunak)

Patch from Lubos Lunak from downstream bug:
https://bugzilla.novell.com/show_bug.cgi?id=518603

"
The patch fixes it - 'toolkit' was NULL at the old place, only created by the
call to 'CreateHiddenWindow'. I guess the patch is safe and correct.
"
Comment 8 Wolfgang Rosenauer [:wolfiR] 2009-10-07 21:56:01 PDT
http://hg.mozilla.org/mozilla-central/rev/1a9b6d37e99a
Comment 9 Wolfgang Rosenauer [:wolfiR] 2009-10-07 21:57:45 PDT
Comment on attachment 405030 [details] [diff] [review]
patch f(rom Lubos Lunak)

Pretty low risk for 1.9.2 and solves an annoying visual behaviour on Linux desktops
Comment 10 :Gavin Sharp [email: gavin@gavinsharp.com] 2009-12-01 17:18:11 PST
Comment on attachment 405030 [details] [diff] [review]
patch f(rom Lubos Lunak)

approval1.9.2 requests aren't currently being monitored, since we're nearing RC freeze and there are too many outstanding requests, so I'm clearing this request. Feel free to re-request approval if you are confident that it's worth drivers' time to consider whether this non-blocker needs to land for 1.9.2 at this stage.
Comment 11 Ginn Chen 2009-12-15 03:23:15 PST
I filed Bug 534845, for distros build firefox with --enable-startup-notification, you may also want to get it fixed.
Comment 12 Robert Kaiser (not working on stability any more) 2009-12-15 09:00:52 PST
If this is not being looked at for 1.9.2 right now just for logistical purposes, can we request for it to go straight into 1.9.1 so our current releases work well with KDE?
Comment 13 Wolfgang Rosenauer [:wolfiR] 2010-01-25 06:51:40 PST
Comment on attachment 405030 [details] [diff] [review]
patch f(rom Lubos Lunak)

requesting approval for next possible release.
(cannot cancel the original one for some reason)
Comment 14 Mike Beltzner [:beltzner, not reading bugmail] 2010-04-05 10:39:55 PDT
Comment on attachment 405030 [details] [diff] [review]
patch f(rom Lubos Lunak)

a=beltzner for 1.9.2.4
Comment 15 Wolfgang Rosenauer [:wolfiR] 2010-04-06 00:02:28 PDT
mozilla-1.9.2:
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/965a31dcde02
Comment 16 Ginn Chen 2010-04-06 00:53:16 PDT
You need to fix Bug 534845 on 1.9.2 branch to make restart situation work.

Note You need to log in before you can comment on or make changes to this bug.