Signnature filepath which contains Ja chars is displayed as garbage after it is saved.

VERIFIED DUPLICATE of bug 41083

Status

P3
normal
VERIFIED DUPLICATE of bug 41083
19 years ago
10 years ago

People

(Reporter: ji, Assigned: alecf)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
When settting the file path for signature file, if the file path contains Ja
characters, the file path is displayed as garbage after it is saved and 
redisplayed on the account setting window.

Steps of reproduce:
1. Create a signature file with a Japanese filename under a Japanese directory
name.
2. Launch Mail.
3. Select Edit | Mail/News Account Settings.
4. Click on the Choose button to set the signature file path which contains 
Japanese characters. On linux, the Ja directory and file name is displayed as 
garbage on the file dialog window (bug 41600).
5. Save the setting. Close the account setting window.
6. Open the account setting window again.
You'll see the signature file path is displayed as garbage.
(Reporter)

Comment 1

19 years ago
Created attachment 9658 [details]
attached a screen shot.

Comment 2

19 years ago
Looks like UTF-8 string is shown, need UTF8ToUCS2?
Scott, please reassign to the owner of this.
Assignee: nhotta → putterman

Comment 3

19 years ago
reassigning to alecf
Assignee: putterman → alecf
Target Milestone: --- → M17

Comment 4

18 years ago
Marking as M18 and nominating for nsbeta3.
Keywords: nsbeta3
Target Milestone: M17 → M18
(Assignee)

Comment 5

18 years ago
Ugh. This is essentially the same as my nsbeta2 bug, bug 41083.. which I'm not 
sure I'll be able to fix for beta2 (but I'll make comments in that bug)
Status: NEW → ASSIGNED
(Reporter)

Comment 6

18 years ago
Marked this as a dup of 41083.

*** This bug has been marked as a duplicate of 41083 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

18 years ago
Marked it as verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.